Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My xcode uses 5G ram on my computer (mac os 10.7.5). My mac has 2.7 GHz Interl Core i7 processor, I have 8G memory.

If I open my xcode, I can not do anything. What is wrong with this xcode? anyone can help.

I restarted my computer, I reinstalled the latest xcode, none of these helped. I can not do anything with xcode.

Anyone has any suggestion how to fix the issue. Thanks

share|improve this question

migrated from stackoverflow.com Mar 20 '13 at 7:38

This question came from our site for professional and enthusiast programmers.

    
500%. Is that all? That still leaves 3 cores totally ununtilised :-) –  paxdiablo Mar 20 '13 at 0:14
    
Do you have this usage on every project (I doubt that) or on a specific one ? Check headers imports, project headers search path maybe. See stackoverflow.com/questions/6225603/… –  Vinzzz Mar 20 '13 at 0:16
    
Have you tried resetting Xcode with defaults delete com.apple.Xcode; rm -rf ~/Library/Application\ Support/Xcode? Make sure to back up the settings first. –  nneonneo Mar 20 '13 at 0:20
    
No kidding. I am very frustrated about the stupid xcode. –  Emmy Mar 20 '13 at 0:21
    
How do I back up settings? I never did that. –  Emmy Mar 20 '13 at 0:22
show 5 more comments

3 Answers

If your xcode is consuming that much of RAM and CPU, then surely it is doing few things in background.

Indexing your project. And your project is most likely to be a big one.

Downloading Components and Documentations. Try UnCheck these.

enter image description here

share|improve this answer
add comment

I met the same case, and found out that the "comparing" view would cause the problem(both when committing to SVN and switching to "Show the version Editor" in the Main window)

But until now I don't find any solution after trying to upgrade to 4.6.2, restart and open other projects.

share|improve this answer
add comment

You can try the following steps:

  • Find your project file.
  • Right-click on it, then select Show Package Contents.
  • Next, delete project.xcworkspace.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.