Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There was a similar question 2 years ago, but everyone confused guest/host OS.

After installing VirtualBox on my Windows 7 box, I can no longer ping it or access it from anywhere within the LAN. To be clear, I cannot access/ping the Host machine. I can still use my host to access any other computer on the network or browse the internet.

From what I can see, VirtualBox installed a virtual network card. enter image description here

The moment I right click and disable it, my Host OS is suddenly accessible and can be pinged within the network.

How can I resolve this problem (short of uninstalling VirtualBox)?

share|improve this question
1  
What happens when you try to ping it? Does ARP work? Does a ping get sent? – David Schwartz Mar 20 '13 at 16:54
    
@DavidSchwartz The ping just times out. As in Request timed out. – AngryHacker Mar 20 '13 at 17:03
    
Right, but does the ping get sent? Does ARP work? What happens? (Request timed out is just telling you that you didn't get a reply. The next thing you have to do is look to see how far you got.) – David Schwartz Mar 20 '13 at 17:11
    
@DavidSchwartz So I terminal into a random box on the network and attempt to ping my box (e.g. host box). The ping fails with Request timed out. I am not sure how to tell whether ARP works. I can tell you that I can ping my host OS from the guest OS - that works fine. – AngryHacker Mar 20 '13 at 17:34
    
Does the ping get sent though? Does the machine you are pinging receive the ping? Does it send a response? You need to do some troubleshooting. – David Schwartz Mar 20 '13 at 17:42
up vote 1 down vote accepted

Apparently you are using VirtualBox in Host-Only Network mode. That means, that the VMs can communicate with each other and the host but not the outside world. Try changing the Network Settings to Bridge mode.

share|improve this answer
    
Do I change the network settings on the Settings for the Virtual Machine or in Preferences/Network in the VirtualBox Manager? And specifically what do I change? – AngryHacker Mar 20 '13 at 16:18
    
@AngryHacker: See the line in the linked-to instructions that start with "To change a virtual machine's virtual network interface to "host only" mode:" -- you can probably do something similar to put it into a non-"Host-only networking" mode. – martineau Mar 20 '13 at 17:27
    
@martineau That was the plan, but I can't find anywhere in the article an explanation on how to take the driver from host only mode. – AngryHacker Mar 20 '13 at 17:38
    
@AngryHacker: right click the stopped VM, choose "Settings". In the new window select "Network" in the right column. In the right column where it says "Attached to" change from "Host-only Adapter" to "NAT" or "Bridge Adapter". – Simon Mar 21 '13 at 7:22
    
@Simon All that does is change the connection method on a specific Virtual Machine. The actual network card is still Host Only (as u see in the screenshot). – AngryHacker Mar 21 '13 at 18:24

The same situation happened on me as well.

I figured the VirtualBox adapter somehow must have higher priority than other LAN.

Try and see if this helps

https://www.virtualbox.org/ticket/8698

Workaround -

  1. Open up Network and Sharing Center
  2. Click 'Change Adapter Settings'
  3. Right click 'VirtualBox Host-Only Network', go to Properties
  4. Double click "Internet Protocol Version 4 (TCP/IPv4)' under 'This connection uses the following items'.
  5. In the Properties page, click "Advanced..."
  6. In the "Advanced TCP/IP Settings", tab "IP Settings", uncheck the box marked "Automatic Metic" and type in 800 or higher
share|improve this answer
    
While the link might provide an answer it can quickly become outdated. Please include the main points from the link within your answer. Thanks. – Matthew Williams Jul 7 '14 at 7:48
1  
Workaround - 1. Open up Network and Sharing Center 2. Click 'Change Adapter Settings' 3. Right click 'VirtualBox Host-Only Network', go to Properties 4. Double click "Internet Protocol Version 4 (TCP/IPv4)' under 'This connection uses the following items'. 5. In the Properties page, click "Advanced..." 6. In the "Advanced TCP/IP Settings", tab "IP Settings", uncheck the box marked "Automatic Metic" and type in 800 or higher. – Sunny Mok Jul 14 '14 at 4:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .