Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an older Dell XPS B800r that I use for Windows 98, and I recently reformatted and reinstalled Windows 98 2nd Ed. All of the installation of the drivers went fine, until I came to the installation of the modem driver.
The modem is an Agere, and it uses a 'soft modem,' the driver is named:

 'modem830.exe'.

When I execute the file, the installation progress bar 'hangs' or gets stuck near the end (approx 95%) before eventually disappearing without any error messages. Upon checking in the Device Manager, there is no Modem listed (before and after reboot).

The modem card came with installation software which installs modem tools along with the modem driver (modem830.exe); however, I wanted to see if I could just install the driver without the additional tools. The installation from the disk with the tools works ok, for some reason.

Thinking that chipset drivers might need updating, I have also tried installation of these files:

 Z0377C01.exe (Intel 800 Series Integrated Chipset, v. 2.00, A01 )
 Z4314R03.exe (Intel Security Driver)
 Z0377C04.exe (software install utility)

All three were offered by Dell for my computer. After installation of these, the modem driver still would not install. Could this be a port problem (port closed?), possibly?

Thanks for any help or leads. Will post additional info as needed.

Regards.

share|improve this question
    
1) Did the modem work before the re-installation? 2) You should really start with the chipset drivers, reboot and only then add other drivers. This because some chipset drivers changed the way PCI devices were detected. 3) No errors at all, including in the event logs? –  Hennes Mar 20 '13 at 16:56
    
Thanks for your suggestions. In answer to your questions: 1) Yes, the modem did work before the re-installation. 2) Thanks for the suggestion on the installation order. The download pages for the chipset driver files did not give an order of installation, and that left me wondering. 3) I will check on the logs, when I get back to the pc's location, to see if there were errors. –  buck1112 Mar 20 '13 at 20:38
    
I think item 2 (chipset drivers first) was mainly a problem with older computers. It should no longer be needed on a modern computer with a modern ACPI compliant BIOS. Then again your laptop is rather old. –  Hennes Mar 20 '13 at 21:12
    
I wiped the disk and reinstalled Win98 2nd Ed and then added the three chipset update files (listed above) before installing any other driver, but I still wind up with the modem not installing. Could the problem be with the order in which the chipset update files are installed, or maybe not all three are needed? Thanks. –  buck1112 Mar 26 '13 at 14:13
    
I never had problems with the order of them (that is not saying that it is not possible, just that I never had problems with it). I did have problems with win95 and 98 when ealy PCI IDs changes when those drivers were not installed. However if I started with them it usually worked. –  Hennes Mar 26 '13 at 19:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.