Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I open a local file of type .mng (custom file type), FireFox always asks which application to open the .mng file - it uses the Windows File Associations and knows that the .mng file extension is associated with my program. However, the box is greyed out that says, "Always do this for files of this type.". I looked in Tools > Options > Applications and I don't see the MNG file type in the list. Is there a reason that FireFox will not let me select "Always do this.." in the confirmation box, so I am not prompted every time?

EDIT: FYI; I also want to "download" this file locally using the "file://" prompt!

Using FireFox 17.0.3 ESR

share|improve this question
add comment

1 Answer

If you need to perform a default action on a local "download" file, i.e.,if you are using "file://", I would suggest that you manually edit the mimetypes.rdf file and add the particular extension that is causing you such pain.

For web page use and working with MIMETYPES read the below:

From the Firefox/Seamonkey KB on File types and download actions

You may not be able to set an automatic download action. This can occur when a misconfigured web server assigns an incorrect MIME type, such as "application/octet-stream" (shown here in SeaMonkey 1.x)

enter image description here

or if the server assigns "Content-Disposition: attachment" to the file download (as shown here in SeaMonkey 1.x).

enter image description here

When this happens, the option to always perform the same action will either be "grayed-out" or, in Firefox, selecting the "Do this automatically" option will not seem to have an effect and you will again be asked what to do when you next encounter that file type (see below for related bug reports). There is little you can do in these cases because the problem is at the server end.

Note: the MIME type of a downloaded file, and whether it should be handled as an attachment, is only shown in the SeaMonkey 1.x "Opening" dialog. This information does not appear in Firefox or in SeaMonkey 2.

Why are correct MIME types important?

Example of an incorrect MIME type result If the web server or application reports an incorrect MIME type for content, a web browser has no way, according to the HTTP specification, of knowing that the author actually intended the content to be processed and displayed in a way different from that implied by the reported MIME type.

Some other web browsers, such as Microsoft Internet Explorer, try to allow for misconfigured web servers and applications by guessing what the correct MIME type should be. This has sheltered many web administrators from their own errors, since Internet Explorer will continue to process content as expected even though the web server is misconfigured, e.g. displays an image which is reported to be plain text.

Serving content using the correct MIME type can also be important for security reasons; it's possible for malicious content to affect the user's computer by pretending to be a safe type of document when it is in fact not.

share|improve this answer
    
Even if the URL is file://? I don't think there is a MIME because it is coming from local disk –  staticx Mar 21 '13 at 0:10
2  
No, but there can be if you are getting the file from a repository. In your case, I would suggest that if you are using "file://" that you manually edit the mimetypes.rdf file and add the particular extension that is causing you such pain. kb.mozillazine.org/MimeTypes.rdf –  G Koe Mar 21 '13 at 0:18
    
blog.mcfang.com/2008/02/18/… –  staticx Mar 21 '13 at 0:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.