Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I issued the command:

apt-get install tor

and I got the following result:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 tor : Depends: libevent-2.0-5 (>= 2.0.10-stable) but it is not installable
       Depends: libssl1.0.0 (>= 1.0.0) but it is not installable
E: Broken packages

Could someone explain why this happened? I'm new to Linux.

share|improve this question
    
I'm using the following command: apt-get install tor –  Steffen Mar 20 '13 at 23:33
    
Fixed it this way: I added the following code to etc/apt/sources.list: deb deb.torproject.org/torproject.org <DISTRIBUTION> main DISTRIBUTION = Your distribution name! To get your distribution name, use this: lsb_release -c After adding it, I could run it without errors! –  Steffen Mar 20 '13 at 23:51
    
Please add your solution as an answer and accept it so the question can be marked as solved. –  terdon Mar 21 '13 at 12:39

1 Answer 1

  1. Make sure that you don't have any 3rd party repositories in your /etc/apt/source.list file and inside /etc/apt/sources.list.d directory. If so, comment them out.
  2. Run apt-get update and apt-get upgrade commands.
  3. Run apt-get autoremove and apt-get -f install commands.

Hope that the above helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.