Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using xampp 1.7.7 in my Windows 7 and I can't access PHP application hosted in my PC through LAN in any other computer.

But if I disable Firewall then every thing goes fine; But I dont want to disable firewall.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Maybe try allowing the specific HTTP ports through the firewall

Go into the Windows Firewall settings and click the "Advanced" button, and in the next dialog click "Inbound Rules" - click "New Rule"

  1. In the rule type window, choose Port
  2. In the program window, leave All Programs selected
  3. In protocols and ports, leave protocol as TCP, and Local Ports should be "Specific Ports", enter 80,443
  4. In the scope window, don't enter any specific ip addresses
  5. In the action window, Allow the Connection
  6. In the profile window, leave them all ticked
  7. And finally, in the name, call it something useful, like HTTP_ports
share|improve this answer

First of all, firewall on host is blocking your connection. If you are using Windows firewall or any other firewall You need to make an excaption rule for XAMPP.

So, on computer where is web site hosted go to Control panel-> Windows Firewall and uncheck Don't allow exceptions checkbox. Now open Exceptions tab and click on a button Add program and locate Xampp and Apache. Add them to firewall exception rule.

Maybe you should do this test on some Virtual Machine (VMware, Virtualbox..etc) becouse opening ports and adding exceptions if this machine is connected to Internet is not secure.

share|improve this answer
    
Didn't Succeeded –  Kaviarasan K K Mar 21 '13 at 6:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.