Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After running :vimgrep I'll get a column to the left that with indicators pointing at lines where things were found. After editing, how can I hide this quickfix column?

Let me know if the question is unclear. Thanks!

share|improve this question

2 Answers 2

up vote 1 down vote accepted

That column on the left is the "sign column" and those markers are "signs". You can read about them in :h signs.

Both your diagnostic and your solution are completely wrong.

  1. Signs are created manually (by you) or programatically (by a script). Never automatically (by Vim itself).

  2. The sign column appears when signs are created for the current buffer and disappears when there are no signs left.

  3. Neither :vim nor :grep create signs by default and there's no available setting for that.

  4. The content of the quickfix list may be used to create signs but, like with the commands above, it is not done automatically and there's no setting for that.

  5. Conclusion: that sign column and those signs are there only because of a third party script. Find that script, see if this behaviour can be altered with an option and, if not, see if you can change its code or submit an issue to the author.

share|improve this answer
    
Ah, thanks. I had previously encountered the docs about signs but I thought it wasn't pertinent precisely because the docs were talking about creating signs manually and I assumed it was automatically generated. –  Sherwin Yu Mar 21 '13 at 17:30
    
I tried to find which plugin / script was causing this; to confirm what you've said, starting vim with -u NONE disables sign behavior. Curiously though, when running with a blank .vimrc, however, the behavior persists. –  Sherwin Yu Mar 21 '13 at 17:41
    
Try with --noplugin. –  romainl Mar 21 '13 at 17:57

I found a hacky solution: just run :vimgrep (or grep) again with a search term that doesn't exist; the gutter column will disappear because nothing is found.

Example: :vimgrep /asdlfjalskdfj/ .

This is similar to another hack: turning off search highlighting by searching for a nonexistent string!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.