Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My kids (somehow) talked me into installing Minecraft on my iMac. I have separate accounts for them with the Parental Controls feature enabled for each account. When they start up Minecraft on their account it prompts for admin access as expected. If I enter my username/password and click 'Allow Always' the dialog goes away for a couple of seconds then pops back up. If I click 'Allow Once' the games starts up and they can play.

How can I allow them to always play without requiring me to come over and enter my info?

share|improve this question
I'm not sure that it's enough for a proper answer, but you could just extract the minecraft.jar file from the (or grab it directly from the website, under 'Minecraft for Linux / Other'), and set it up with some kind of launcher so that your kids can run it locally. – evilsoup Mar 21 '13 at 14:45
up vote 0 down vote accepted

I had a similar issue and this thread on Ask helped me to solve it. Instead of creating a new script named MyMinecraft as one answer suggested I modified the Java loader.

First I backed up the JavaApplicationStub file. Then I created a new script with that same name and edited the contents to be:

java -jar -Xms512m -Xmx1024m /Applications/

Then made that file executable for all users:

chmod a+x JavaApplicationStub

This allowed Minecraft to load for me without the prompt.

share|improve this answer

You might want to manually approve the java runtime, and minecraft by going into the preferences and adding it to the list. I'm not sure if the JRE can be individually approved though, but you can always try.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .