Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just upgraded my operating system to Windows 8, and am trying to use my external hard drive enclosure. However, when I try to use it, it is uselessly slow. Often times Windows explorer will freeze when trying to open up My Computer, and it can take up to a minute just to view the contents of a particular folder, let alone copying files.

This drive worked just fine on Windows 7, so I know the drive is not at fault. It is also in NTFS format. For clarity here is the external hard drive enclosure I am using: http://www.rocketfishproducts.com/products/computer-accessories/RF-AHD35.html

Is there something that can be done about this?

Thank you for your time.

share|improve this question

Sounds to me like a drivers issue for the usb controllers, would check the motherboards manufacturer to see if there is a windows 8 driver available. I had one recently that kept blue screening halfway through transfering data. Good luck

share|improve this answer

Did you use the upgrade adviser before moving over to windows 8. It is well known that device compatibility is an issue when moving from Windows 7 to windows 8, unfortunately.

Like Spryno said, search for a Windows * driver....or hope that a fix(or driver) will be made available some time soon. I have had my Win8 Pro disc since launch, still haven't installed it and I wont be for some time.

Also, you can try going here: Microsoft Fix It

MS Fix it may find a solution or compatible driver.

share|improve this answer

I had a similar issue I couldn't figure out - I bought a USB2 PCI card for $10 and let W8 install it's own drivers - USB worked fine. Mine turned out to be the BIOS which needed an update for the USB problem. W8 treated the on board USB as USB1.1 not 2.0

share|improve this answer
    
I'm using a USB 3.0 device... I'll have to check that – Oliver Spryn Mar 21 '13 at 18:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .