Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I only want to disable SSH access but retain FTP access to user myuser. I've perform the following command usermod -s /bin/false myuser. Upon testing, it disable both SSH and FTP.

  1. How can I reverse this?

  2. How can I disable SSH access for myuser but allow FTP access?

share|improve this question
    
What OS and distribution are you using? What SSH and FTP server software? –  depquid Mar 21 '13 at 16:54
    
@depquid Debian Squeeze, Pro FTP, how do I find out what type of SSH? –  IMB Mar 21 '13 at 16:55
1  
To get the ssh version run ssh -V. To reverse what you did do usermod -s /bin/bash. –  terdon Mar 21 '13 at 17:04
    
@terdon Thanks OpenSSH_5.5p1 Debian-6+squeeze3, OpenSSL 0.9.8o 01 Jun 2010 –  IMB Mar 21 '13 at 17:05

1 Answer 1

up vote 1 down vote accepted

To allow FTP access, try turning off ProFTPD's check for a valid shell by setting the following in /etc/proftpd.conf:

RequireValidShell Off

Source: http://www.proftpd.org/docs/faq/faq_full.html#AEN267

WARNING: If you have other users on the system whose FTP access has been disabled by setting their shell to one that is not a valid login shell, making this directive change will give them FTP access.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.