Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently moved and had to re-setup a new wireless network at home. Unfortunately, my laptop can't seem to see any wireless network (the available wireless network list is always empty). There's a non protected wireless network near my home, and even though it doesn't appear in the list, it automatically connects to it. Using my girlfriend's laptop, I can tell that there is about 10 networks in the area (including mine). My laptop doesn't see any of them. I must have triggered something because I never had any problem of the kind before.

I'm using Windows XP SP2
Intel(R) PRO/Wireless 2915ABG Network Connection

What should I be on the look out for? What are the possible causes?

share|improve this question

6 Answers 6

up vote 1 down vote accepted

What usually works for me is just to going to Device Manager and right clicking on the card and clicking Uninstall. After that all I have to do is click Scan for Hardware Changes. And it reinstalls and works

share|improve this answer
    
Tried that, but no luck. It reinstalled but same situation. Still connect to that non protected network, but the list is still empty. –  nicon Oct 18 '09 at 23:33
1  
Have you tied using your wireless card's own software? You may want to check to see if wireless zeroconfig started correctly. Right click my computer and go to manage then services and right click Wireless Zero Config and click Restart. –  thegreyspot Oct 19 '09 at 13:02
    
I finally managed to try Intel Software (couldn't do it last night, their download site was in maintenance) and it worked! The software see all the networks available. –  nicon Oct 19 '09 at 23:27
    
Good old intel proset! Good to hear to bad you couldnt use wireless zero config:( (You may want to try and see if you can switch it back to "Let windows manage my wireless connections", It might work again) –  thegreyspot Oct 19 '09 at 23:59

First, to see if all network services are running, launch msconfig. Under the Services tab, make sure that there are check-marks next to Network Connections, Network locations and Wireless Zero Configuration. Then re-boot.

Ensure that in Wireless Network Connection Properties, Use Windows to configure my wireless network settings is checked.
But if your wireless adapter came with a wireless utility of its own, install it, or better still get the latest version from the manufacturer's site.

This article: Some Network and Dial-Up Connections Icons May Be Missing mentions several things to try. Have a look at all of them. The most useful might be:

regsvr32 netshell.dll
regsvr32 netcfgx.dll
regsvr32 netman.dll

If nothing works, you might verify your installation against the Wireless section in this article, a rather encyclopedic list of everything that needs to be done for setting up a wireless network. Advice can also be found in the much shorter Wireless - Basic Configuration.

Other things to try include running WinSock XP Fix (create a system restore point first), and, of course, all the other suggestions in this thread.

share|improve this answer
    
I can't seem to find that "Use Windows to configure my wireless network settings" box. I know it's supposed to be under the Wireless Networks tab in the Wireless Network Connection Properties. Problem is... the tab just ain't there. –  nicon Oct 19 '09 at 0:21
    
I don't have XP, but see this : pcreview.co.uk/forums/thread-248185.php –  harrymc Oct 19 '09 at 8:29
    
Exactly what I tought, I followed those steps, but the Wireless Network tab is nowhere to be seen. I'll now try to investigate why it isn't there. –  nicon Oct 19 '09 at 22:57
    
This shouldn't happen if Wireless Zero Configuration is running. Check also that "Client for Microsoft Networks" is on for the network connection. –  harrymc Oct 20 '09 at 5:52

Since you aren't getting ANY wireless signals the first thing I would check is that you didn't accidentally turn the switch for the wireless off. Many laptops have a switch to manually turn off the wireless.

If that switch is on then I would make sure the device is enabled in the Device Manager:

Right click on Computer/Manage/Device Manager

Make sure there is no issue with the wireless network adapter.

share|improve this answer
3  
He's connecting to a network, so he really can't have WiFi turned off. –  CarlF Oct 18 '09 at 15:13

I am having a similar problem with XP SP2 on lap top..was working just fine, now I can't connect to my wireless lan. I get a balloon on the bottom of the page saying that there are networks available click on to see...go to "choose a wireless connection" and nothing is there. It says no connections within range..I am 6 feet from the wireless modem. the adapter is ok?? it is on..tried a USB plug in adapter with the same results. Sounds like an xp issue but don't know where to look...all other computers in the house connect just fine

share|improve this answer
    
Steve, you need to start your own question thread if you want to get helpful answers to your specific problem –  AdamV Nov 11 '09 at 7:20

Is the network you are connecting to using 802.11a? Perhaps there is a setting for your card to turn off the b/g part and only look for networks using a? (still should not auto connect to a foreign AP though, really)

share|improve this answer

follow this steps, maybe a virus change this settings at registry.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\Ndisuio

there look for

Start key, value must be hexa 3 ("Start"=dword:00000003) Tag key value must be hexa C ("Tag"=dword:0000000C)

close registry and reboot. After boot check networks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.