Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I run Windows 8 in a VMWare VM. Today I got that lovely "your computer will reboot in 15 minutes to install important updates". So, I rebooted it. It did all the "applying update" magic and then when it started back up it hung at starting up. It didn't actually hang, but it just didn't do anything. (no disk activity or anything, but little spinner is still going)

Here's the fun part. This isn't the first time this happened either. I have two VMs setup in a similar way, both Windows 8 Enterprise running under VMWare 9, but on different physical machines and with slightly different configurations.

I already "fixed" one of my machines which had this exact problem, which resulted in having to do a System Restore and having to redo the setup of a lot of stuff. Now, it just now happened with this VM though which is much more important and I'd like to avoid a system restore. However, I can't get into a safe mode or anything like that and I don't see any kind of way to do anything but a system restore.

Is there another option to fix this botched Windows Update without doing a system restore?

share|improve this question
    
So are you saying you didn't make a snapshot before you did the update? If you did, revert to that and try again. Either way, include this kind of info because it matters to the people who answer here. Include everything you did so we don't waste time thinking about solutions that you already tried out. –  SPRBRN Mar 22 '13 at 16:35
    
@rxt I have a rather old VMWare snapshot, but no I didn't do a snapshot just before the update –  Earlz Mar 22 '13 at 17:06
    
Try booting in safe mode and if that works, remove the hotfixes then try to apply them again. –  Mark Allen Mar 22 '13 at 17:15
    
@MarkAllen what safe mode? I tried to get into it, but it never actually comes up. See also superuser.com/questions/476187/… I had the problem that my computer couldn't get to the point what I could get into it I guess –  Earlz Mar 22 '13 at 17:31
    
@Earlz I didn't know about the shift-f8 vs f8 thing, sorry. If it's not making it that far, then I don't see an alternative to what you've already done, sorry. :( –  Mark Allen Mar 22 '13 at 20:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.