Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows XP Pro sp3 machine which no longer accepts remote desktop incoming connections. This machine is used only with some demo equipment so there's no telling when it stopped working. I have checked the usual culprits preventing this from working but everything seems good. I've consulted other threads on here and msdn and explored some fixes suggested but have yet to resolve my issue. I'm just trying to avoid spending the time to rebuild this box.

  • Windows Firewall is turned off
  • machine is pingable (both ip and hostname)
  • I can RDP out of this XP machine to other machines on the network (including Win7 boxes)
  • removed antivirus

I found a suggestion online that disabling the Windows Firewall ICS Sharing service would resolve the ignored connection request but it had no effect.

I've tried to find an article or something that tells me all the places that remote desktop connection hooks into the OS (services, specific versions of dll's, etc) so that I may find that something is disabled or not running that may resolve my issue. I've not found an article such as this as of yet.

The windows event logs are clear of any messages relating to this issue.

share|improve this question

3 Answers 3

Can you have a look at the key fDenyTSConnections at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server change the value to 0 if it’s 1.

share|improve this answer
    
Value was already zero. –  TWood Apr 8 '13 at 18:12

Check sysdm.cpl's Remote tab and make sure "Allow incoming connections" is checked. An update may have possibly reverted that setting back to default.

share|improve this answer
    
The connection is allowed –  TWood Apr 8 '13 at 18:13

The issue is known in here: http://support.microsoft.com/kb/969084

Solution: http://support.microsoft.com/kb/951608

share|improve this answer
    
followed kb 951608 to manually update registry, rebooted. No change. –  TWood Apr 8 '13 at 18:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.