Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the following problem while using tmux under Ubuntu. I enabled mouse-mode to switch between panes by clicking the mouse, but the switching is not always successful, and random characters appear in my terminal.

screenshot: screenshot

My tmux.conf file:

unbind %
bind | split-window -h
bind - split-window -v

# Mouse mode
set -g mode-mouse on
set -g mouse-resize-pane on
set -g mouse-select-pane on
set -g mouse-select-window on
set mouse-utf8 off

# Active pane border colour
set-option -g pane-active-border-fg yellow

# Load layout
bind q source-file ~/.tmux/dev_laptop
bind Q source-file ~/.tmux/dev_mon

# Show Pane Number
set-option -g status-left '#P'

I'm using the latest tmux (version 1.7), and the problem is terminal independent (tried it with xterm, gnome-terminal, guake).

Others experienced the same problem, but the solutions didn't work for me:
1) http://code.google.com/p/iterm2/issues/detail?id=855
2) Why are random letters inserted in my tmux session?

share|improve this question
    
Have you resolved this? – Mario Oct 10 '13 at 16:41

I think you need to remove the line

set mouse-utf8 off

My environment is similar to yours. I use Ubuntu 12.10, Tmux 1.7, Gnome-terminal and Konsole. I don't have this problem without this line. I have not found character setting in Gnome-terminal but in Konsole it's Utf-8.

Side note: Don't use mouse, keyboard is much much faster.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .