Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Periodically when I select a menu command, the label or selected option gets "stuck" on screen and won't go away. I can close all open applications, including whichever one I was using when it got stuck, but it still won't go away.

In the screenshot below, I opened an new instance of IE just to show how the label stays on top. The label was not created by this instance of IE.

Lingering menu command label

(I added the circle in MS Paint. That part isn't stuck.)

The label that gets stuck is the first menu command I select in IE. If a label is already stuck, a new one does not get stuck (regardless of which instance(s) of IE are involved). Based on this knowledge, I now just open IE on my secondary monitor, carefully open the context menu so the Properties command is in the bottom corner, and click it. This is not a solution.

The floating label never moves and is transparent to mouse input (if I click it, it's as if I clicked the item behind it).

The label does not go away if I close all running applications. I haven't tried stopping services or closing system tray items like Live Mesh.

The label does go away if I change the screen resolution and then change it back.

Any ideas how I can stop this from happening? It's happened a half dozen times and it's becoming quite disrupting to my work.

share|improve this question
    
I had this happen a LOT in the betas of Win7, particularly when executing in a VM. It doesn't happen anymore, but I'm not sure exactly when it changed. I suggest updating your video card driver and, one by one, disabling startup programs until it stops. I think it was either my driver, UltraMon, or WinSplit Revolution, but never narrowed it down. –  OwenP Oct 18 '09 at 17:43
1  
I have some programs do that in Vista. I don't have a solution. –  Henk Oct 18 '09 at 22:05
9  
Happens. Start - Run - "tskill dwm" or kill DWM.EXE from task manager, it will restart instantly with menu items gone. –  Петър Петров Oct 7 '13 at 18:47
1  
Happened to me some minutes ago. It wasn't a tooltip, but a menu item stuck on screen when IE11 devtools crashed. The tskill dwn trick didn't work, while changing the color depth did. –  MaxArt Jan 15 at 14:56
1  
Internet Explorer 11 seems to be a big offender of leaving these ghost menu selections on the screen. –  Matthew Lock Mar 20 at 1:04
show 5 more comments

9 Answers

Enough tskill dwm commands seems to stop dwm re-starting, so you may need to restart the Desktop Window Manager Session Manager in Services:

enter image description here

share|improve this answer
add comment
up vote 194 down vote accepted

The problem was introduced back in Windows 2000 when fading menu items were added. Originally, the feature was added in kernel-mode code and was tightly integrated into portions of the UI. Since it worked so well, it ended up staying there. The problem has appeared from time to time, but no one has had a reliable way to reproduce it in the kernel debugger to get it fixed.

The same effect can be achieved without changing the screen resolution or color depth. Go to Start -> Run -> and type tskill dwm. This command will reset the desktop window manager without the need to change the screen resolution.

Changing the screen resolution or color depth also resets the desktop window manager, so it's always been a workaround for the bug when it appears. Either of these solutions will fix the problem.

share|improve this answer
3  
I am using Windows 7 Ultimate. This is how I resolved the issue. Go to Control Panel > Change Theme. Set the theme to High Contrast White. The ghosted menu should go away. Set your theme back to what it was. –  Hossein Aarabi Jul 11 '12 at 17:06
    
I had this issue with other overlays on Windows 8 too. I was remoted in at the time. My fix was just now was to disconnect from remote desktop and reconnect. –  GotDibbs Mar 25 '13 at 15:43
1  
I just had a balloon tip's shadow stuck on screen (on top of everything else!). Changing resolutions didn't work for me, but changing color depth did. I switched the depth to 16-bit, then back to 32-bit. That seemed to do the trick. –  ADTC Apr 19 '13 at 14:08
19  
Start - Run - tskill dwm - always fixes it - this really forces DWM to restart. –  Петър Петров Oct 7 '13 at 18:44
2  
Had this happen today for the first time ever. After using tskill dwm, it goes away, but has come back with the first menu item I select afterward. Here's hoping it doesn't come back after I reboot. [crosses fingers] –  mouseas Jan 30 at 23:40
show 8 more comments

The "Rotate to normal" hotkey CTRL + ALT + UpArrow can be used to clear the stuck menu, if your graphics card driver supports it.

(I know for a fact this works with Intel graphics, but can't vouch for any others.)

share|improve this answer
    
Doesn't work for me. –  Andreas Rejbrand Jan 13 at 0:47
    
@AndreasRejbrand I have updated my answer to be more specific –  benrwb Jan 13 at 13:46
    
@benrwd: OK, I see, it's a feature of some video graphics drivers. Well, it certainly is a shortcut for those with this hotkey. (But I suppose the fix is only temporary -- the next time you click a native Win32 popup menu item, it will stick again?) –  Andreas Rejbrand Jan 13 at 14:11
    
@AndreasRejbrand Yes it is only a temporary fix, the best solution is to disable the "Fade out Menu Items after clicking" setting as detailed in other answers. –  benrwb Jan 15 at 7:57
    
This is a default hotkey on Intel integrated graphics drivers, although it's often disabled because people hit it accidentally and then don't know how to change it back. –  nullability Feb 5 at 19:31
add comment

I recently started getting this problem on a Windows 7 Professional Thinkpad W510 and a generic i7 workstation running Windows 7 Ultimate. Having it happen to both machines was a source of interest and typing 'tskill dwm' would do things like break screenshot and felt like a bad work around.

In my case I have found the problem was the Logitech SetPoint process crashing. Disabling the on screen notification modifications it makes to the system seems to have solved the tooltip problem.

Hopefully the core idea here helps someone:- Some tool that manipulates the Aero overlay may be interfering.

share|improve this answer
add comment

I think it's faster to just change the colour depth. Once you've changed and clicked Apply, you can just answer NO to the "Do you want to keep these settings?" prompt. It will revert to your original colour depth (with the problem solved). Btw, I recommend you to not change the resolution because doing so will force Windows to recalculate window sizes and positions... twice! It's noticeably slower than changing colour depth.

Anyway this is definitely a video problem in Windows, so the only sure-fire way (other than restarting) would be to force Windows to fully refresh the video buffer. You can do that by killing dwm.exe, but changing colour depth is faster (no need to search long list of processes), safer (no need to risk your Windows' stability) and easier to grasp for novices.

Adding to this: The important thing may be to say "NO" when prompted to "keep the settings". If you say yes, then the orphan menu pieces may return.

share|improve this answer
add comment

Right click Computer, Properties, Advanced System Settings, Advanced Tab, Performance-Settings, Uncheck both:

  • Fade or Slide menus into view and
  • Fade out Menu Items after clicking

Fixed.

share|improve this answer
    
I know this is rather old but I just ran into this problem recently and this is the one that fixed it for me. –  jefffan24 Apr 22 '13 at 13:22
    
worked for me, too bad it reset my theme –  Daniel Nov 15 '13 at 4:06
add comment

Last time I saw this was in Windows 2000 where it happened to me occasionally.

I suppose, a workaround would be to disable menu items fading out after clicking in the Performance options:

alt text

share|improve this answer
19  
Took me a trip to Google to see how to get to that screen: - Right Click Computer and select Properties from menu - Choose Advanced System Settings - In the Performance area, click Settings –  Al Crowley Apr 8 '11 at 11:50
20  
@AlCrowley: Or simply type "performance" into the start menu and choose "Adjust the appearance and performance of Windows". –  Јοеу Apr 8 '11 at 16:42
2  
This solution worked for me on Windows 7. Thanks. –  Ankur Apr 10 '13 at 6:36
4  
Also if you disable the two checkboxes above contextmenus will appear much faster –  Sven Hecht Nov 3 '13 at 13:33
2  
This is probably the best long term solution. It is only a relatively minor reduction in visual styling (which most people will never notice anyway). Bonus, it makes menu's work just a little faster. –  Chase Jan 3 at 8:13
show 10 more comments

In Windows 7 (and probably Vista), using the task manager to kill "dwm.exe" (it restarts automatically) seems a pretty painless way to get rid of the artifact.

share|improve this answer
14  
Unfortunately this is just a very temporary solution at least for me - even if the stuck menu item disappears after killing dwm.exe a new one gets stuck as soon as I click any menu item again. –  alexteg Jan 18 '11 at 19:36
3  
At first, I thought this would work, but unfortunately alexteg is right. I just tried to kill dwm, and indeed the menu item disappeared, but within a minute a new menu item got stuck (and that's hardly a coincidence, since this Windows bug manifests itself rather seldom). At least, with this approach, you can replace the stuck menu item with a new one, the on-screen position of which you can decide for yourself. –  Andreas Rejbrand Sep 17 '12 at 16:21
1  
Thanks, with superuser.com/a/57021/152255 it works fine. –  orosznyet May 8 '13 at 7:53
    
I combined this with @Joey's answer. Joey's answer seems to stop it from occurring, but doesn't clean up the problem on screen at the moment. This clears out the problem on screen at the moment. Running a full screen DirectX game also seems to clear the problem. –  AJ Henderson Aug 15 '13 at 3:09
    
Even faster, type "tskill dwm" in Run :) –  Петър Петров Oct 7 '13 at 18:45
add comment

I used to get this quite a lot on my home system, running XPPro, along with tool-tip boxes doing the same. Windows Explorer was the app that exposed the oddity most (though that might be because it is on of the utilities most commonly used). Closing/killing applications, as in your case, did nothing but flipping screen resolutions or colour depths did. Also switching to the login screen then logging back in would usually, but not always, do the trick.

I happens very rarely now, though I'm not sure what has changed to reduce the occurrence. I have recently upgraded the graphics card in the machine, but the reduction in occurrence happened noticably before that upgrade took place. My guess is that either a driver update or one of MS's patches has reduced the problem, but that is only a guess. In any case, make sure that you have not missed any updates and make sure you are running the latest stable drivers for your graphics chipset.

share|improve this answer
add comment

protected by Community Oct 26 '11 at 22:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.