Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to switch my left shift+ button with my x+ key on the keyboard. I tried Lshift::x but what happened was BOTH keys now had the functionality of just x. I looked at Problem with rebinding Ctrl to Capslock using Autohotkey and it seems that this could fix my problem but I have no idea how to convert their answer to something that I can use. Would someone be able to do this? Thank you!

Edit, this didn't work:

 #ifWinActive
Shift::
   Gui, 93:+Owner ; prevent display of taskbar button
   Gui, 93:Show, y-99999 NA, Enable nav-hotkeys: x
   Send {LShift Down}
   KeyWait, Shift ; wait until the Shift button is released
   Gui, 93:Cancel
   Send, {LShift Up}
Return

 #IfWinActive , Enable nav-hotkeys: hjkl

   x::Send {Blind}{LShift Up}{Left}{LShift Down}

 #IfWinActive, ; end context-sensitive block

... of course putting the window after the ifwinactive's

share|improve this question
2  
You need two lines Lshift::x and x::Lshift. See Remapping Keys and Buttons. – Bavi_H Mar 23 '13 at 0:20
    
Wow thanks man i feel dumb haha – Cory Mar 23 '13 at 2:59

Two lines are required:

Lshift::x
x::Lshift
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.