Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm creating port forwarding rules on my DD-WRT router (shown below) and want to allow all (any) source networks access. My thought was to specify 0.0.0.0/32 but that is not working. How do I specify this?

enter image description here

share|improve this question
    
try alex's edit to his answer about leaving the field blank or trying 0.0.0.0/0 Leaving the field source net blank is also mentioned in a post here dd-wrt.com/phpBB2/viewtopic.php?p=509730 –  barlop Mar 23 '13 at 4:43
    
That works! I originally had tried this and thought it did not work, but I insufficiently tested it. –  Matt Mar 23 '13 at 18:00
    
Does 0.0.0.0/0 also work? –  barlop Mar 24 '13 at 3:14

2 Answers 2

up vote 3 down vote accepted

There are no "wildcards" for specifying IP address ranges. You need to use subnets instead. You can see examples of subnets in the "Source Net" column.

So instead of 192.168.*.* you need to use 192.168.0.0/16

in DD-WRT I believe you need to leave the field blank in order to set it to 0.0.0.0/0

share|improve this answer
    
Yup, I realized that after I posted and just edited the question. It's the means of specifying all/any source networks that I want to determine. –  Matt Mar 23 '13 at 2:47
    
have you tried to leave it blank? –  Alex P. Mar 23 '13 at 3:44
    
That works! I originally had tried this and thought it did not work, but I insufficiently tested it. I'm going to mark your answer as accepted. Maybe you could edit your response to move the 'in DD-WRT I believe you need to leave the field blank in order to set it to 0.0.0.0/0' sentence to the top, or perhaps remove everything else. –  Matt Mar 23 '13 at 17:59

You probably want to leave this field blank.

I had the exact same question when using the dd-wrt.v24-18946_NEWD-2_K2.6_mega-nv60k firmware on my linksys e3000. For some odd reason using the same port forwarding settings I've used in previous dd-wrt builds did not result in appropriate port forwarding (i.e. nmap always showed my router's external port 80 as filtered). I thought it was likely due to the new source_net field. I was wrong. No combination of subnet settings fixed the problem. I finally fixed things by upgrading my firmware using the ddwrt database as opposed to brainslayer's svn site (the database ended up being more current). I'm currently running dd-wrt.v24-21061_NEWD-2_K2.6_mega-nv60k and port forwarding works without any entry in the source_net field.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.