Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to install glibc-2.12-1.25.el6.i686 on 64 bit RHEL. I understand it has a dependency on the NSSRAWHASH package (I'm using the nss-softokn-freebl-3.12.9-3.el6.i686.rpm package), so I run the following command to install both packages at the same time and resolve the circular dependency between the two.

rpm -ivh glibc-2.12-1.25.el6.i686.rpm nss-softokn-freebl-3.12.9-3.el6.i686.rpm

However, I am still getting the following dependency error ...

error: Failed dependencies:
    libfreebl3.so is needed by glibc-2.12-1.25.el6.i686
    libfreebl3.so(NSSRAWHASH_3.12.3) is needed by glibc-2.12-1.25.el6.i686

I don't see why it is still having dependency issues. Is there some other package I'm missing?

share|improve this question

migrated from stackoverflow.com Mar 23 '13 at 7:28

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer 1

  1. Try installing nss-softokn-freebl-3.12.9-3.el6.i686.rpm first.
  2. Then, locate libfreebl3.so in your system.
  3. Make sure that libfreebl3.so's path (eg. /usr/local/lib) be in $LD_LIBRARY_PATH
  4. Try installing glibc-2.12-1.25.el6.i686 again.
share|improve this answer
    
When I attempt to install nss-softokn-freebl-3.12.9-3.el6.i686.rpm alone, I still get the same exact error for some reason. –  user2150250 Mar 18 '13 at 16:23
    
That's weird. Try to uninstall glibc-2.12-1.25.el6.i686. –  tcurvelo Mar 18 '13 at 16:35
    
Rather, uninstallation of the packages returns an error saying they're not installed. –  user2150250 Mar 18 '13 at 17:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.