Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use SuperDuper! to backup my Mac (running SL 10.6.1) to my LaCie Rugged Hard Disk.

Because I lock my hard drive away when it's not in use everytime I plug it in it gives me a pop-up box saying:

time machine popup box

I always click 'Don't Use' but now it always pops up regardless of what I click.

This seems to have only started since I installed Snow Leopard. When I ran Leopard (10.5) it only appeared once (when I plugged in the HD for the first time).

Is this a new 'feature' that Apple has included in SL? Or is this not normal, and if so how can I fix it?

UPDATE: Sorry Forgot to mention that Time Machine is turned off in system preferences.

share|improve this question
    
I believe this is governed by some hidden file, what does ls -la | grep ' \.' give? –  cobbal Oct 18 '09 at 18:43

4 Answers 4

up vote 8 down vote accepted

A workaround from Stop Time Machine from Nagging About Every External Disk at AFP548:

Every time you plug in a different external disk Time Machine asks if you want to use it for backups. [..] What we need is a way to set a policy that tells Time Machine to not ask about every disk that is plugged in. [..] Here it is:

defaults write com.apple.TimeMachine DoNotOfferNewDisksForBackup -bool YES

share|improve this answer
    
Quick and straight forward, perfect answer. –  Jasarien Oct 19 '09 at 19:28
    
Quality. Thanks! –  OrangeBox Jan 20 '12 at 2:35

If you don't use TM at all you can go into System Preferences > Time Machine and turn it off. This will stop the prompts.

share|improve this answer
    
Sorry Forgot to mention that Time Machine is turned off in system preferences. –  cust0s Oct 18 '09 at 18:27

Small chance (as you did not have this problem in 10.5 Leopard): is SuperDuper! overwriting the whole disk each time? If so, then it might also remove some hidden file that tells Time Machine you want to ignore that disk. (I'm just guessing; maybe that setting is kept in some extended attribute rather than in some hidden file.) If it indeed uses some hidden file, and if SuperDuper! deletes that, then maybe you can set that hidden file to be read-only for SuperDuper!? (Funny !?... ;-))

(Hmmm, this discussion might cover it: Did you schedule an erase-then-copy backup, rather than a Smart Update? This is the kind of thing that TM does when a new drive appears... But you're using Smart Update already.)

Still, Time Machine being switched off, it should not bother you in the first place, so something surely is wrong. Maybe just remove /Library/Preferences/com.apple.TimeMachine.plist and disable it again?

share|improve this answer
    
I have seen weird files like .com.apple.timemachine.supported pop up on my external drives... –  Isaac Waller Oct 18 '09 at 21:21
    
I think that's something else (people also use that to make Time Machine support network drives that are actually not supported...) –  Arjan Oct 18 '09 at 21:22
    
nope it does a 'Smart Update' –  cust0s Oct 18 '09 at 21:24

I thought Hasaan Chop's solution would work for me, but I had to do this:

defaults write /Library/Preferences/com.apple.TimeMachine DoNotOfferNewDisksForBackup -bool YES

Perhaps because I'm on Snow Leopard? Found on Apple Support.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.