Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have updated my Arch system few days ago and since then i lost my network access. Network-manager-applet says "interface eth0 is down". From "dmesg" i have this:

systemd[1]: Cannot add dependency job for unit networkmanager.service, ignoring: Unit networkmanager.service failed to load: No such file or directory. See system logs and 'systemctl status networkmanager.service' for details.

from "sysctl" i got:

networkmanager.service
Loaded: error (Reason: No such file or directory)
Active: inactive (dead)

Reinstaling network service from cd did not help... My Arch knowlage isn't so great (changes all the time, i have no time to track them all) so please, can you help me and tell me what's the problem and how to solve it. I think it might have something to do with replaced "networkservice" service after update but that's only my guess...

share|improve this question
    
it it not called networkmanager.service but NetworkManager.service. Try systemctl disable networkmanager.server, systemctl enable NetworkManager.service, systemctl start NetworkManager.service –  t-8ch Mar 23 '13 at 19:40
    
That did the trick! (of course, i was using "NetworkManager.service") –  guest86 Mar 23 '13 at 21:47
    
Feel free to accept the proper answer I posted :-) –  t-8ch Mar 24 '13 at 8:50
add comment

3 Answers

up vote 1 down vote accepted

The systemd service is called NetworkManager.service, not networkmanager.service.

share|improve this answer
add comment

Recent versions use different naming for the interfaces. I found my "eth0" being reported as "eno1" which is apparently the new naming convention for systemd or udev or something like that. You might want to check your system isn't trying to start with 'systemctl start dhcpcd@eth0.service' and change it to whatever your interface is actually called.

share|improve this answer
add comment

Open the terminal and enter:

ls /sys/class/net

You will see the exact naming of your interfaces. One is the loopback interface (lo), another should be the wireless interface (maybe wlan0) and the one remaining is the ethernet interface. To enable the ethernet at startup, enter at the terminal:

systemctl enable dhcpcd@XXXX

Replace XXXX with the name of your ethernet interface.

To stop systemd from trying to load eth0 (which does not exist anymore) at startup, enter:

systemctl disable dhcpcd@eth0
share|improve this answer
    
I have tried this but i don't know if it helped because first i tried solution described in comment of my question and it solved the problem. P.S. i have only "eth0" and "lo", i don't have wireless net :) –  guest86 Mar 24 '13 at 0:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.