Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've setup a home network using Netgear N300 wireless router (using Windows 7).

I'm trying to get one of my hard drives to be available on the network, so I went to the "sharing" tab of the HD's properties setting and allowed sharing on the HD and turned off password protection so that you don't need a password to access the HD.I also set the permissions to give full control, change, and read access to the "Everyone" group.

From another computer in the network, I tried connecting to the network HD but ultimately got "Access denied" despite the fact that I gave full control to "Everyone".

How do I get the computer to be able to connect to the shared HD?

share|improve this question

2 Answers 2

How did you connect to it?

Assuming all Windows 7 systems here, given what you did above, you should be able to press the Windows key + R and enter the following in the Run dialog that pops up:

\\computername\driveletter$

where computername is the name of the computer (look in Control Panel -> System to find that out) and subtitute the drive letter you shared for driveletter, e.g. c$. If computername doesn't work, try substituting the IP address of the system, e.g. \\192.168.2.15\driverletter$ or similar. What should pop up is an Explorer window displaying the contents of that drive.

Windows 7 has a "Homegroup" feature that you may want to look into if all systems are Windows Vista or higher systems. Control Panel -> Network and Sharing Center -> Choose homegroup and sharing options.

EDIT: I found this which suggests to try the following. You might actually already be in a Homegroup (you may have enabled it during setup), which looks like it disables direct access to network drives (personally I've yet to try out the Homegroup feature). Make sure it's turned off by doing the following:

Open the control panel.

Go to Network and Internet.

Go to HomeGroup.

Click on the blue link "Leave the homegroup."

Another thing to try is enabling File and Printer Sharing and changing a registry key:

Open the control panel.

Go to Network and Internet.

Go to Network and Sharing Center.

In the left column, click on Change advanced sharing settings.

There are two profiles. You probably don’t want this on when you’re on a public network so open Home or Work.

Under the header File and Printer sharing, select the "Turn on…" option.

Open the registry editor.

Navigate all the way to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System.

Right-click in the pane on the right side and add a new DWORD (32-bit).

Give the new setting the name LocalAccountTokenFilterPolicy, Double click on that setting and give it a value of 1.

You may need to reboot after that.

share|improve this answer
    
yea I connected by \\computername\driveletter ... the drive would then appear in My Computer but when I double click the icon it says access denied –  kamikaze_pilot Mar 24 '13 at 1:48
    
I've suggested two other things in the edit above. –  ultrasawblade Mar 24 '13 at 14:28

I don't know whether it's true for Windows after XP, it seems that default shares(drive letter, such as C$, D$) are no longer directly shared by default. So it's better to share the whole drive manually(will be shared as folder) if you're needed. However anonymous with no password access also restricted, so an account with password protected is needed to get your files through network access.

if you just instantly access the network drives through commnad line(Press Start+R buttons, input "cmd" then press enter), type the following command in Command Prompt, example is:

start \\pcA\folderA

pcA > name for remote PC
folderA > name for shared folder in remote PC

or you can use "net use" command to map network drives persistently, there is an example:

net use z: \\pcA\folderA /user:peter 123456 /p:yes

z > drive letter name(A-Z)
peter > user name on remote PC
123456 > password for peter
/p:yes > persistent, (accessible after reboot)


Before I committed, i found on Wiki about administrative shares(default shares)

By default, Windows Vista and newer versions of Windows prevent local accounts from accessing administrative shares through the network.

To enable administrative shares you have to make a registry change. Click on Start Menu and in the search box type ‘regedit’ and press ENTER. Add this registry item:

Hive: HKEY_LOCAL_MACHINE
Key: Software\Microsoft\Windows\CurrentVersion\Policies\System
Name: LocalAccountTokenFilterPolicy
Data Type: REG_DWORD
Value: 1
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.