Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a home wifi network that I want to access remotely via VPN.

I want to access files/folder that I have shared and the internet access through my home wifi (not from my local wifi) - That is I want the default bhaviour of VPN

My router (speedtouch 780WL) at home gets assigned a dynamic ip address from my ISP. In my router I have a feature to assign public IP to a computer. Which I have done so. Hence when my home computer is turned on it is assigned the public ip address of my router.

As a result of the above change in my router configuration the ip that gets assigned to my person computer is like 117.7.3.30 other computers on the same network are assigned ip addresses like 192.168.1.65 , 192.168.1.66 and so on.

The gateway/router ip address within my home netwrok is 192.168.1.254

Now from outside the network I can access 117.7.3.30 ip which accesses my home computer which is perfectly fine.

The problem

In my home computer (windows 7 pro) In the network connection I have created a new incoming network connection using default settings. which has 'Allow other to access my local network' and 'assign ip address automatcally using dhcp' enabled

When I remotely connect to my home network thourgh vpn I can access my files/folders on the network but there is no Internet access.

The VPN connection status says

IPV4 Connectivity no Internet access.  
IPV6 Connectivity no Network access. 

The description says

 DHCP enabled no
 IPv4 address 192.168.1.66
 IPv4 subnet mask 255.255.255.255
 IPv4 default gateway   Empty
 IPv4 DNS server  192.168.1.254
 IPv4 WINS server  Empty
 Netbios over tcpip enabled Yes

Any ideas why internet is not accessible ? My suspicion is the default gateway which is empty in the details of VPN connection should have been 192.168.1.254 which address of the router. Even though in the VPN client connection properties -> Networking IPV4 -> properties -> Advanced -> use default gateway on remote network is checked.

share|improve this question

1 Answer 1

Listed a few things that I needed to so to overcome the same situation on Windows Vista and Windows 7:

  1. Ensure the 'IP Helper' service is running. On my machine having it set to manual wasn't enough for it to start when needed. Definitely needed on the client machine not sure if needed for the server also.

  2. The network setting on the VPN server needed to be static IP addresses not DHCP. As per information posted elsewhere the IP address needs to be on the same network.

I suppose the only new information I posted which I couldn't find else where was the IP helper service. Hence the reason posting this message; for the next unlucky person tearing there hair out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.