Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I created a .bashrc file in the /home directory and then rebooted Linux but now it wont restart.

I am now on a Live CD version of Linux.

Why are many folders not accessible?

share|improve this question

migrated from stackoverflow.com Mar 24 '13 at 10:02

This question came from our site for professional and enthusiast programmers.

    
Are you running as the superuser? If not, you wouldn't have access to all files/folders. Have a look at su/sudo. –  oKtosiTe Mar 24 '13 at 10:04

2 Answers 2

Since you're now using a Live CD, just delete the problematic .bashrc file and reboot into your normal Linux installation.

share|improve this answer
    
i see the .bashrc but it wont let me delete it or edit it. –  user2204072 Mar 24 '13 at 7:50
    
@user2204072 What error do you get? –  Danny Beckett Mar 24 '13 at 7:51
    
the "Delete" option is not selectable. –  user2204072 Mar 24 '13 at 7:51
    
@user2204072 Which distribution of Live CD are you using? Are you sure you're not trying to delete the Live CD's /home/.bashrc? You need to delete the /mnt'd Linux's file. –  Danny Beckett Mar 24 '13 at 7:55
1  
it appears i had to select "open as administrator" and then i was able to delete the stuff in it. i just rebooted and it's working great. –  user2204072 Mar 24 '13 at 8:04

Boot to a Live CD and delete the file. You may need to mount your drive as read write.

To find your drive ID, run df -h. You're looking for something like /dev/sda1. Then run

mkdir foo
sudo mount /dev/sda1 -o remount,rw foo/
sudo rm foo/home/your_user/.bashrc

replacing /dev/sda1 with your device ID.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.