Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Last night I started to delete 100GB worth of VirtualBox disk images on a MBP running Lion. A dialog box opened saying that the trash was preparing to empty, but nothing happened for a good 20 minutes. I had to shut the computer down, so I cancelled the process and waited another 10 minutes or so for the window to disappear. When it did, the trash appeared to be emptied, but I never got back that 100GB of space.

I've tried some of the suggestions from similar questions on this site, but so far nothing has worked. There's nothing in the Trash, in ~/.Trash, or in /user/username/.Trash.

Any ideas?

share|improve this question
    
Have you tried using a file system visualizer to determine where all the disk space is used? –  Daniel Beck Mar 24 '13 at 10:56
    
If that doesn't help, maybe try verifying the disk from Disk Utility. No idea if that fixes any wrong size information but worth a shot. –  slhck Mar 24 '13 at 11:01
    
If you have Time Machine turned on, it might be being maintained in a local snapshot. In which case the Finder will show the space as available but command-line tools will show it in use, and About This Mac's Storage tab will show it used for Backups. Local snapshots are deleted automatically when the disk gets above 80% full, so the space is effectively available for other things. –  Gordon Davisson Mar 24 '13 at 14:26
    
I think @GordonDavisson may be on to something. Some Mac systems use ZFS, and so deleted files may still be referred to by ZFS snapshots until the snapshots are destroyed. The system may do this for you as space starts to become scarce. I'm not sure. –  killermist Mar 28 '13 at 1:08
    
I'm having a similar problem. I deleted my iPhoto library 200 GB and now wanted to copy it back from time machine.. but I cant because I never got the 200 GB (from the deleted iPhoto library) back... so I can't copy the one from TM because I have not enough free space on the disk... all trashes are empty. :-( –  otmezger Aug 19 '13 at 8:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.