Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to capture an image from my webcam (Raspberry Pi, Rasbpbian). Using the following command:

uvccapture -v

I get the following output:

Using videodevice: /dev/video0
Saving images to: snap.jpg
Image size: 320x240
Taking snapshot every 0 seconds
Taking images using mmap
Unable to set format: 22.
 Init v4L2 failed !! exit fatal

Any suggestions? What exactly is error 22? I didn't have any luck googling it. I tried adding the -r flag but instead it then produced the error /dev/video0 does not support read i/o.

I've managed to get the webcam to work using motion but it's not suitable for my needs.

Thanks!

share|improve this question

Try to add the -m switch. It tells the program to use another color format. It worked fine with my camera on my RPi.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .