Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have configured the cisco switch with the following:

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname protec
!
enable secret 5 $1$3GSJ$A0TryiEdaSegNfA2kr6kg0
enable password cisco
!

!
ip subnet-zero
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 172.30.2.180 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 172.30.2.1
banner motd ^C
*******************************
YOU MUST LOG ON
*******************************
^C
!
line con 0
 password Aaniyafreya78
 login
 transport input none
 stopbits 1
line vty 0 4
 password cisco
 login
line vty 5 15
 login
!
end

I have also turned my firwall & anti virus off.

When i try to telnet to the switch from my Laptop which has windows 7 installed, i receive the below error:

C:\Users\Windows7>telnet 172.30.2.1
Connecting To 172.30.2.1...Could not open connection to the host, on port 23: Connect failed

why am i receiving this error? i can ping on a general base, but i cannot ping the above ip nor can i telnet to it. what else do i need to do on the switch to be able to access it remotely?

Thanks

share|improve this question
    
what do you mean by "I can ping on a general base"? – onxx Mar 25 '13 at 1:54
    
I had this same problem. The problem actually lies with the computer itself. Telnet is disabled by default on Windows, you have to activate it. Please review the instructions below, I will add this as the answer if it solves your problem. wikihow.com/Activate-Telnet-in-Windows-7 – Jordan Granados May 8 '15 at 9:55

Can you ping the ip address? Probably not.... this is because you are missing your vlan 1 db entry need to assign a interface to vlan 1.


If you do a "show vlan brief" what results to you get?

Assign your interface that the data cable is connected to to the the vlan; I chose interface fastethernet 0/1 for this example.

Commands:
1.conf t
2.int fa0/1
3.switchport access vlan 1
4.no shut


Now try to ping the switch before using telnet.

Also, you don't need to put password cisco on the vty code unless you wont to enforce a different password set from the already specified user password.

share|improve this answer
    
protec#sh vlan brief VLAN Name Status Ports ---- -------------------------------- --------- ----- default active Fa0/1, Fa0/2,Fa0/3,Fa0/4,Fa0/5, Fa0/6, 1002 fddi-default active 1003 token-ring-default active 1004 fddinet-default active 1005 trnet-default active protec# – Patel Mar 29 '13 at 17:19
    
yeah you still need assign interfaces to vlan 1 (Think of it like its a new virtual switch).. use my config above to assign port fa0/1 then plug in you pc and try to ping it ps <-> switch. Also, your example of where you trying to connect is not the switch but the default-gateway. – onxx Apr 2 '13 at 21:14

Switch IP is 172.30.2.180, but the OP's example shows he's telnet-ing to 172.30.2.1. Or am I missing something...?

interface VLAN1
 ip address 172.30.2.180 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
share|improve this answer
    
good catch but he still needs assign ports for connectivity to comm with his default gateway... which is 172.30.2.1 – onxx Apr 2 '13 at 21:12

From line console try to telnet the ip address of the switch but first verify the state of phisycal interface with "Show ip int brief".

share|improve this answer
    
This answer can be a bit clearer. Can you edit it to add an explanation? – bwDraco Jun 21 '15 at 22:39

The default-gateway is for the switch to be managed remotely, from another network (thats probably from another IP range). Default-gateway address is usually assigned as the ip address of the L3 device (router's interface) connected to the switch. But if you are in VLAN 1 of your switch ' protec ', you need to telnet to the ip address of interface VLAN 1 :-

telnet 172.30.2.180

This oughta work! Enjoy

share|improve this answer

if this is a fairly new equipment or an old with with security measures updated on it, more than likely telnet is disabled as a communication protocol, due to its insecure nature. try connecting using ssh protocol (download putty if you have to; if you don't know what it is, just Google it)

share|improve this answer
    
This wouldn't fix his problem, most likely the computer has no communication to the switch as the code indicates. – onxx Mar 25 '13 at 0:23
    
then waht do you get as a response to telnet 172.30.2.1 22 command ? If it is the same, you may be right and your connection to this device might have been cut off totally by some firewall or routing rule, but if you are getting a response like openSSH..., my answer still holds. Just check it. it won't hurt – MelBurslan Mar 25 '13 at 4:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .