Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am having a strange problem.

I just finished setting up my wonderful Raspberry PI, and it works great... except for the fact that it is not compatible with my Mac OSX Keyboard NOTE: I have the wired version - they just don't sell that anymore.

I can type perfectly well - letters and numbers work fine. But, if I attempt to write ", the output is @. If I write the @ symbol, " comes out. This is extremely annoying - I was hoping to use the raspberry pi to test LAN networks in Python - the " symbol is essential.

How can I remap my keyboard to fix this?

share|improve this question
    
It sounds like a UK/US keyboard layout issue similar to this raspberrypi.org/phpBB3/viewtopic.php?f=28&t=38081 – David Marshall Mar 24 '13 at 20:56
    
I have reposted this question here – xxmbabanexx Mar 25 '13 at 6:29
    
Please don't crosspost. If you feel you'd have a better chance on the raspi SE site, flag it for migration instead – Journeyman Geek Mar 25 '13 at 7:34

You're using a UK keyboard when you think you have a US keyboard - the 2 on a UK keyboard maps to " when it maps to a @ on the US/international one.

In theory, using raspi-config should let you change the keyboard configuration, or by changing the locale. The former seems to be the 'logical' way but I can't quite get that to work. The latter should work by changing it from a gb locale, to a US locale, since the raspi is so very british.

share|improve this answer

Out of the box the Raspberry Pi keyboard configuration is set to 'gb' (Great Britain). Keep in mind who is producing this cool little device. :)

Raspbian's X client doesn't provide a way to change this via some GUI application(that I know of). Just edit the keyboard configuration file manually using some text editor. I use vim in this example.

$ sudo vim /etc/default/keyboard

Find the following line:

  XKBLAYOUT="gb"

Change it to (assuming you want US keyboard layout):

XKBLAYOUT="us"

Reboot.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .