Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 8 x64 and would like to install the .NET Framework 3.5. I've downloaded the full package dotnetfx35 from http://www.microsoft.com/en-us/download/details.aspx?id=25150. Installation fails with Error: 0x800f081f the source files could not be found.

Regression:

How can I install .NET Framework 3.5 on Windows 8?

Error: 0x800f081f the source files could not be found

share|improve this question
    
Are you sure that the F drive is where iso is mounted? Double check in Explorer an make sure you're pointing the /Source option to the correct location. –  Windos Mar 24 '13 at 20:44
    
yes, I'm dead sure about it –  Mohammad Mar 24 '13 at 20:45
2  
What iso are you using and where did you get it from? –  Windos Mar 24 '13 at 21:21
    
If you can access Windows Update, you can install it through the Control Panel as described in msdn.microsoft.com/en-us/library/hh506443.aspx –  David Marshall Mar 24 '13 at 22:47
    
@DavidMarshall I don't agree with your statement that when you can access Windows Update, that .NET Framework 3.5 can be installed through the Control Panel. In our case the "Control Panel" method returns the 0x800f081f error code where the dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:D:\sources\sxs /LimitAccess command and a newer 8.1 DVD does result in a successful installation of the .NET Framework 3.5. –  Pro Backup Apr 5 at 18:52

2 Answers 2

Download the Enterprise Evaluation ISO, mount it and now point to this ISO. This ISO includes the SxS folder.

share|improve this answer
    
And make sure that you don't make any typos in the dism.exe command. I for example mistyped a lower case x (/featurename:NetFx3) instead of the required upper case X (/featurename:NetFX3). –  Pro Backup Apr 5 at 18:46

Enable .Net Framework in Control Panel » Uninstall or Change Programs. Turn Windows Features and check the box Update Windows.

share|improve this answer
3  
Please familiarize yourself with the formatting options on this site, and use proper capitalization in your posts. Maybe you could expand your answer a little to explain in more detail why this solves the problem? Thank you. –  slhck Mar 24 '13 at 21:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.