Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I can't get sound through headphone port on laptop.

I use HP Compaq 6730b with Linux Debian Squeeze on board.

On Windows 7 (another PC) headphones work normally.

Internal laptop speakers also work normally.

Simple OS reboot doesn't help.

alsamixer has no any options for headphones.

Things I've tried:

First I've got my sound card model:

# cat /proc/asound/card*/codec* | grep -i codec
Codec: Analog Devices AD1984A
Codec: LSI ID 1040

After that in file /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz I find
below lines for my card:

AD1884A / AD1883 / AD1984A / AD1984B
====================================
  desktop       3-stack desktop (default)
  laptop        laptop with HP jack sensing
  mobile        mobile devices with HP jack sensing
  thinkpad      Lenovo Thinkpad X300
  touchsmart    HP Touchsmart

I've added line options snd-hda-intel model=laptop at the end of the file
/etc/modprobe.d/alsa-base.conf and restarted alsa:

# alsa force-reload
Terminating processes: 2490 2548.
Unloading ALSA sound driver modules: snd-hda-codec-analog snd-hda-intel snd-hda-codec snd-hwdep snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc (failed: modules still loaded: snd-hda-codec-analog snd-hda-codec snd-hwdep snd-pcm snd-timer snd-page-alloc).
Loading ALSA sound driver modules: snd-hda-codec-analog snd-hda-intel snd-hda-codec snd-hwdep snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.
#

I've tried this with all possible options from file HD-Audio-Models.txt.gz, but headphones still
don't work.

I'm afraid that headphone jack could be broken, but still hope it is just software problem.

Thanks in advance for help.

Short system information:

# cat /proc/version 
Linux version 2.6.32-5-686 (Debian 2.6.32-48squeeze1) (dannf@debian.org) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Mon Feb 25 01:04:36 UTC 2013

Edited:

I have checked jack on laptop using Ubuntu Live CD and after that headphones have started working. I can't explain this. Possibly I changed something more, but I don't know, what exactly.

share|improve this question
1  
On Debian, sometimes the volume slider can be set normally, yet the mute button on Master, Wave or similar is still active. Are you sure this isn't the case? I believe the mute/unmute button on alsamixer is m. –  oKtosiTe Mar 24 '13 at 21:55
    
Unfortunately it didn't help. The situation is that if I disconnect headphones, I can hear music through internal speakers. But if I connect headphones, I can't hear any sound. Mute/unmute command m in alsamixer changes behavior of internal speakers, but doesn't affects on headphones. –  yurko Mar 24 '13 at 22:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.