Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've just bought a Synology DiskStation DS412+ and put 2 x 3TB Western Digital Red drives in it, set up in RAID 0. It's currently plugged in to my gigabit Netgear switch.

I created a user with full permissions on the NAS, created a share, mapped a drive on my Windows 7 PC (also gigabit ethernet) and tried copying some files, but I'm getting painfully slow transfer speeds (< 40KB/s - yes, kilobytes, it's not a typo!

Does anyone have any ideas why it'd be so slow? There's loads of reports online of people getting > 80MB/s from this NAS.

I've copied files from this PC to my MacBook Pro in the past and got decent enough speeds so it shouldn't be an issue with the NIC on this PC, or (hopefully) the Netgear switch it's going through.

Thanks

Edit - Resources are pretty low.. Resources

share|improve this question
    
if you log onto the management page, is your resource consumption reasonable (CPU/RAM)? whats it detect your network connection as? –  Frank Thomas Mar 24 '13 at 23:32
    
Added an image to show resources, they're pretty low.. can't actually find the page where it tells you what the network's connected at :| I was looking at it a few hours ago but can't find it again. Pretty sure it said 1000 Full Duplex or something, but any idea where I find the page again? –  BT643 Mar 24 '13 at 23:46
    
on my DS209+ (DSM 4.1), its under Control Panel -> Network -> Network Interface tab, under 'Network Status'. if its not present on your version, Try ssh'ing into the nas as root (same passwd as 'admin'), and run this: 'dmesg | grep -i duplex' to see your link speed and duplex. –  Frank Thomas Mar 25 '13 at 1:50

2 Answers 2

up vote 2 down vote accepted

Doh! Turned out it was the switch causing the issue :/

Didn't realise most stuff was plugged into my router rather than the switch.

share|improve this answer

Just to share my experience with a slow Synology in case it is useful to others.

My Synology DS411j (DSM v4.2) suddenly became slow on all operations:

  • File access was slow and unreliable (shares would become unavailable)
  • Webinterface was very slow and unresponsive

The DSM Notifications showed an occasional I/O Error on one of the drives. The SMART status showed it as OK, but after I ran a full test, the drive was flagged as faulty.

After I removed the drive, the NAS went into emergency mode, but the performance improved incredibly. Given how difficult it was to run the SMART test (as I said, DSM interface was not very responsive) removing the drive would have been a simpler test.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.