Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Windows 7 and I also have an XP box on Oracle VM (this will become relevant in the following explanation). My problem is: Until yesterday my pendrive was recognized, I could read and write files, everything was normal, today it's not.

Every other USB device works correctly (mouse, printer, keyboard and even a 3G modem, which is basically a write-only USB drive), and now comes the really unexpected part: for some obscure reason Oracle VirtualBox recognizes my pendrive, and I can mount it on my XP box! I can actually access it normally while inside the XP box, but not on my Windows 7. This makes me believe that, somehow, Windows is recognizing it but not... making it available, though I'm not sure this even makes sense, technically speaking.

Following recommendations, I went to "Disk Management", and surprisingly it recognizes my removable disk, however, it only recognizes it as "Disk 1 - Removable" and nothing else, while VM Virtualbox recognizes it as "Kingston Data Traveller".

ScreenShot of Disk Management:

enter image description here

ScreenShot of Vbox:

enter image description here

I also discovered another interesting thing: My neighbour happens to have a flash drive too, so I asked for his for testing purposes, and surprisingly it presents the exact same problems as mine (I should point out that coincidently, both flash drives are "Kingston Data Travellers", even though his is 4gb and mine 8gb, sadly I don't have a non-Kingston flash drive to test)

How can I fix this situation?

Thanks in advance!

Edit: I would like to point out that :

  • I already tried Hardware Device Problems Fix-it from Microsoft.

  • I already tried different USB slots.

  • I already went to "Device Manager", unninstalled "USB mass storage", removed the USB and reinserted the USB. I was then prompted with "Installing new device", "Install successful", but afterwards I still couldn't access the flash drive.

  • I went to cmd > "diskpart" and tried to enable "automount", but it was useless, since it was already enabled.

  • I tried directly going to the driver it was supposed to be mounted in (G:/) directly, even though it didn't appear in "My Computer" (without success, obviously).

  • Finally, I tried using a system restore point.

  • I also tried rebooting after doing all of the above.

  • Furthermore, it's usefull pointing out that I just booted from the USB Flash Drive (I had Ubuntu Live Cd there), and discovered more two things: 1) The BIOS recognizes the USB (since it was able to load the OS from ti) and 2) I could mount the USB in Ubuntu.

share|improve this question
    
Did you set up VirtualBox to pass the UBS device through to the guest? –  ta.speot.is Mar 25 '13 at 3:47
    
Yes, it recognizes the USB as "Kingstom data traveler" (which is correct), while windows only recognzies it as "removable disk". Hold on, I'm going to post a picture illustrating that. –  ShizukaSM Mar 25 '13 at 3:53

1 Answer 1

Virtualbox is grabbing it for the guest. Trying unchecking it in the Devices menu item. When I did it, it reappeared to the host.

share|improve this answer
    
Sadly it couldn't be it, since it started giving said problem with Virtualbox closed (I randomly discovered later on that Virtualbox recognized, though), but I gave it a try anyways, and it didn't work. –  ShizukaSM Mar 25 '13 at 17:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.