Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Microsoft lync makes my laptop boot very slowly and if I disable it from startup, the laptop boots fine and quick. However the issue is, if I start lync again, it puts an entry to startup. So I end up disabling again and again before every boot. I try to put my laptop into sleep only as much possible, however there are many times I need to start up. So, please suggest how to do any of the following?

  1. How to remove a program from start up, programatically or a windows setting?
  2. How to disable Microsoft lync to stop putting an entry into startup?
share|improve this question

migrated from stackoverflow.com Mar 25 '13 at 8:11

This question came from our site for professional and enthusiast programmers.

2  
There should be a way to turn it off in its options. Else see blogs.microsoft.co.il/blogs/yuval14/archive/2011/10/27/… –  Anirudh Ramanathan Mar 25 '13 at 6:05
    
Yes manually we have. I need to do it with a program or automatically in any manner, with a script that would run before the system shuts down or something. –  Naresh Mar 25 '13 at 6:07
1  
You could write a batch-script to do the registry hack that post suggests. –  Anirudh Ramanathan Mar 25 '13 at 6:08
    
Cool, I did not have to write a script. I just made the flag to 0 and it does not write to start up anymore and also its removed from startup. Thank you for your help. –  Naresh Mar 25 '13 at 6:18
7  
Open Lync. Then Tools > Options > Personalize > Uncheck the 'Automatically start Lync when windows starts' and it should get solved. imgur.com/YnXXsFn –  Shivaranjan Mar 25 '13 at 8:28

4 Answers 4

up vote 1 down vote accepted

Turn off logging in your Lync client. The logging functionality is what is causing the startup delay, not the client itself. Only use logging during diagnostics.

share|improve this answer
    
How to turn of logging? –  Nam G VU Oct 25 at 12:43

You can also configure Lync so that it doesn't start up with Windows. On the sign-in screen, click the configure gear and choose Tools -> Options. Select Personal and un-check "Automatically start Lync when I log on to Windows"

share|improve this answer

You can also uninstall Lync if you don't need it (part of the Microsoft Office).

Go to the Control Panel - Programs and Features and right click on Microsoft Office 2013 and choose Change.

enter image description here

Now you can continue to Add or Remove Featues and uncheck the Lync feature:

enter image description here

share|improve this answer

Microsoft has dodged this to allow Lync to continue annoying users. The options to Change has become "Do you want a quick or slow repair?".

  1. Go to Run (or Windows+R).
  2. Type msconfig.exe and Click OK.
  3. Go to Start Up options, then go to Task Manager and change Lync to ge to Disabled.

Seems to work after rebooting once.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.