Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have windows 7 professional 64bit with 4GB of RAM.

It displays in System Properties 4GB installed and in Resource Monitor correctly shows 4096MB and 2MB reserved for HW.

The bios shows 4096MB and the overlapped memory is on. Motherboard is ASUS p7p55d-e.

The OS uses only 3.1 GB ram as if it was a 32-bit os. Why?

Tried changing bios configuration regardless and set windows boot option to use /not use Max memory and so on....

BUT I still have the limit of 3.1GB RAM max allocated.

Can someone help me?

Maybe the OS installation is corrupted? Some new update? Or something else software/OS related? Or... I don't know....

With the command line with administrative rights

bcdedit /set pae ForceEnable

seems to fix the issue and only increases to 3.4GB instead of 3.1GB.

Any idea how I can use all of my 4GB ram?


EDIT: yes os is x64 As MichaelKjörling said it's seems working as if it was a 32-bit OS

currently with the

bcdedit /set pae ForceEnable

the ram peak it's at 3.5/3.6 GB

Using SysInternal Process Explorer set refresh interval to 0.5s and saw the peak ram in the graph is 3.5/3.6 GB RAM.

With VM on it's stable on 3.1GB and doesn't go over it, but I think maybe it's a win7 memory manager? or something like "superfetch memory caching"?

[cant'post image need 10 reputation, sorry it's not my fault this time :)]

thx for help.


The peak is 3.5 / 3.6 GB

ram graph - peak is 3.5/3.6 GB

PICTURE 2 Monitor Resource (IT lang)

from left to right in the legend:

  • Reserverd (gray)
  • Used (green)
  • Modified (orange)
  • StandBy (blue)
  • Free (light blue)



My question is not related with the others one tagged, because it's a differnt problem:

It is no BIOS related, neither some "Advanced Boot Option in the OS".

otherwise I've not 4 GB Tot ram available (see Pic.2)

thx for help.


Windows 7 Tweaks, Tricks,...

Optimize Memory

In addition to turning OFF unnecessary processes, there are a couple tweaks that will force Windows to use MORE of the ram memory than the system is set to use by default. Using MORE memory FOR YOUR applications means the system is faster and there are fewer hard drive accesses. You want more memory to be USED by YOUR applications... that's why you paid for it.

Run Regedit and go to:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ FileSystem\NtfsMemoryUSage

Change it from 0 to 2.

Just below that location is this key, this registry tweak will increase your hard disk cache size The Large System Cache option is one that can improve your disk I/O performance up to 50%! Change from 0 to 1.


By default, Microsoft probably keeps the memory demands set as low as possible at installation - so they can sell upgrades to a wider market of users who have older computers with limited ram.

share|improve this question

migrated from Mar 25 '13 at 12:24

This question came from our site for system and network administrators.

marked as duplicate by Ƭᴇcʜιᴇ007, 8088, Dave, oKtosiTe, Kaze Mar 25 '13 at 18:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Wait a minute. The title says x64 so 64-bit, but the question says the OS ... is a 32bit os. Please double-check the system properties (Win + Pause, or Control Panel - System); is your installed OS 32-bit or 64-bit? If it's actually 32-bit, that would perfectly explain what you are seeing. – Michael Kjörling Mar 25 '13 at 12:28
@MichaelKjörling I think he meant to say The OS uses only 3.1 GB of RAM as if it was a 32-bit OS – Mar 25 '13 at 12:30 I think it's worth getting clarification on. – Michael Kjörling Mar 25 '13 at 12:32
Where do you get the information that the OS only uses 3.1GB ram? (Perhaps provide a screenshot so we can prove you wrong) – Alvin Wong Mar 25 '13 at 12:32
[update question: yes i'm using x64 os, and monitor ram with SysInternal process explorer] Maybe it's somenthing related with Power Saving too? – Raffaello Mar 25 '13 at 13:02
up vote 4 down vote accepted

I don't see a problem. Your 2nd Picture is showing 4GB of RAM installed. 2.6GB is being actively used and 1.4GB is standby RAM which is like a cache for old/pending data/files that costs very little to keep around but can be freed up if an active application needs it. This is normal and by having standby data it makes your system faster as its not disk bound all the time.

Just because your peak usages of 3.1GB/3.6GB does not mean that you only have 4GB. The system is reporting that the applications are not filling the RAM and its using the rest for cache. Which is great. 8GB in that system might be overkill.

share|improve this answer
my peek usage was 3.1 before ran the bcdedit command line, after it was on 3.5 / 3.6 GB. Testing with mem opt that alloc all available memory. Yeah, maybe it's memory optimizer too fault. :) thx – Raffaello Mar 25 '13 at 14:17

BIOS update? Seems that the OS does not get the full memory - PCIe buffer space not being remapped by a bad bios / crappy chipset. X64 OS can not work around that limitations, sadly.

share|improve this answer
Bios is updated with last version. – Raffaello Mar 25 '13 at 13:00
Then crappy hardware. Happens. Basically the PCIE-Area is mapped into the lower 4gb memory - so you have less memory available. Time to buy more memory. – TomTom Mar 25 '13 at 14:17
maybe you're right.. thx. – Raffaello Mar 25 '13 at 19:36

It could be your Video Card, using some "shared" ram. It happens to me with a Radeon 6310HD on Linux.

Even having dedicated memory, it allocates some RAM too.

What is your graphic card model?

share|improve this answer
it's an oldone, nVidia GEForce 9500 GT 1GB RAM – Raffaello Mar 25 '13 at 13:31
It's old and it uses shared memory:… This could be your "problem". Pre-allocated shared memory. – nwildner Mar 25 '13 at 13:39
I don't think so, the Hardware reservation Memory in resource monitor is 2MB only [added picture in question], perhaps i'm not sure about that, maybe the PCI-E need some extra ram. – Raffaello Mar 25 '13 at 14:00

Not the answer you're looking for? Browse other questions tagged .