Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Windows 8 Enterprise on a quad core machine with 8GB of RAM. The performance is excellent and applications are launched amazingly fast. Even heavy ones, like Microsoft Visual Studio. That is until I decide to switch to Metro layout. Most metro apps are slow to launch. After the launch they are pretty fast and work smoothly. But loading the first screen takes at least 10 seconds. For instance if I click the Mail app icon, I have to wait at least 10 seconds to see my email list!

This video (posted by somebody else) explains the problem precisly.

The guy is opening a video using desktop Windows Media Player in the beginning. The video starts playing in milliseconds. The he tries to play it metro video player. In this case he has to wait more than 10 seconds until he can see the video playing.

share|improve this question
So what's the question? – Mark Allen Mar 25 '13 at 19:06
Why is that!? :) Anything I can do? This way the whole metro UI is almost useless. I can't wait for 10" to see my emails. And it's not 10" the first time. It's 10" everytime the email app is launched after shutting it down. – papadi Mar 25 '13 at 19:26
Every knows that they are crap. Use the desktop and ignore the new StartScreen and all those apps. – magicandre1981 Mar 25 '13 at 20:58
Outside of defragmenting your hard drive and maybe doing something fancy with either an SSD or a USB drive, I don't know how you'd speed it up. Do standalone apps work quickly? (By standalone I mean any app that doesn't rely on the network - an email app might run slow if your email server is slow, for example.) – Mark Allen Mar 25 '13 at 21:29
For example the "Photos" app took about three seconds to load for me, just now. Then much less (almost instant) on the next run. – Mark Allen Mar 25 '13 at 21:29

There is an advanced option in IE (accelerated graphics) that turning it on will somehow solve the problem. The apps will run much faster. But the disadvantage is that it adds to the CPU load. I have the same issue and no optimal solution yet.

share|improve this answer
Are you talking about hardware-accelerated graphics? Isn't that supposed to take the pressure off of the CPU and onto the GPU? – MatthewSot Apr 27 '13 at 0:07
Anyways, this seems to be the answer - if in IE your hardware accelerated graphics setting is unchecked, checking that will let Windows use your GPU to display HTML content (not sure about XAML/.NET apps tho...) – MatthewSot Apr 27 '13 at 0:07
Well, IE 10 has the option for enabling software rendering. This is categorized under "Accelerated graphics" in the advanced tab: "Use software rendering instead of GPU rendering". By default it is unchecked. – amir Apr 27 '13 at 5:20
Ah, you're right, I was thinking that the option was to use GPU rendering instead of software rendering, sorry :\ Interesting, though, that CPU rendering would run better, maybe it has something to do with your graphics driver? I've seen people with the exact opposite problem, it's checked and when they uncheck it they get huge performance boosts. Glad it worked for you, though, and hopefully it works for papadi – MatthewSot Apr 27 '13 at 5:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.