Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
  • Chrome Version Version 25.0.1364.172 m
  • Operating System (Windows 8

I seem to be having a problem with Google Chrome saving my passwords. I have tried for a while now to save my Lycos chat password and the box appears saying

Do you want to save this password

And within 1 second it's gone, well before I can click on it.

Any idea as what I can do to make the option stay where it pops up until I have chosen one of the 2 options?

share|improve this question
    
See if there's an option on that website to keep you logged in, if it does you'll be logged in automatically and won't need to have your passwords save - which I might say is a not very secure thing to do. – Alex Mar 25 '13 at 18:43

Alternatively you can look at a service like LastPass. It integrates into Chrome. Auto-fills usernames and passwords. Prompts to save them but also allows you to directly enter them into the 'Vault'

share|improve this answer

One possible workaround is to enter an invalid password first. Login fails, there is no redirect and the save dialog remains. Save the invalid password so that Chrome has an entry for the website. Now login manually using the valid password and Chrome will automatically update the entry.

share|improve this answer

I got a low-tech solution. By trial and error worked out exactly where the Save Password button appeared on the screen by referencing it with the bookmarks bar. You could physically mark it with a bit of sticky paper. Logged in by using the return button (left hand) instead of mouse click and clicked on the button as it appeared. Didn't expect it to work but it did! The only vaguely good thing that's happened to me today.

share|improve this answer

I don't believe there is any way of changing the timing of this feature. It is hard coded.

share|improve this answer
2  
It is usually on form submit, I believe. But once the page changes (www.domain.com/login to www.domain.com/myProfile/RecentStuff) it generally will go away. So if the page is logging in then moving them somewhere else you would have to catch it before the move... Speculation based off of personal experience... – AthomSfere Mar 25 '13 at 17:45

I had the same issue, I FIXED it putting a wrong password, closing / open the browser then putting the correct password.

share|improve this answer

Simply go to settings>advanced settings and uncheck box "offer to save your web passwords"

Exit settings

Open a web page,then return to settings>advanced settings and check box "offer to save web passwords"

Worked for me...

share|improve this answer

Hi I was facing this problem from long back.After login that remember password prompts too quick to click on save button.

After long debugging I found that in my home page(after login) there is "change password" form was there in code,Initially its hidden but when we click on "change password" it show as popup.When page found successful login it fills that form internally because this form content 3 type="password" fields.Because of auto-fill property of browser. That's why remember password prompts too quick.

Solution: Initially I key those 3 password field as type="text" but when user click on "change password" link , internally it changes their type from text to password.

When user successful login to home page, browser doesn't find any password field so that it doesn't auto-fill any data that's why it remember password box doesn't disappears too quick it remain showing on page unless we hide it.

share|improve this answer
    
This doesn't actually the question. Your home page has nothing to do with the OPs problem. – DavidPostill May 21 at 9:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .