Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been using Komodo Edit to work on a Django project.

It works great except for one little annoyance: When I am editing Django template files, Komodo likes to put red squiggly lines underneath the first HTML tag that follows a Django tag, because it thinks it is an invalid HTML doc (although it isn't, it just has Django template tags/filters in it).

Note that this red squiggly line is called a "Linter error" in the docs that I can find.

Is there some way to turn off this red squiggly for only a specific type of language? It's nice to have when working on Python code but it's annoying to have a red squiggly on every single one of my Django templates.

share|improve this question
up vote 2 down vote accepted

I was able to get a response with a workaround for this on the ActiveState forums:

I needed to go to

<komodo_dir>/lib/mozilla/extensions/django_language@ActiveState.com/components/

and edit koDjango_UDL_Language.py.

Adding the following method to the class turns off the linter for django files only:

def get_linter(self):
    return None
share|improve this answer

You might ask on one of Activestate's KOMODO mail lists. The devs read it, so you'll most likely get a good answer.

share|improve this answer
    
thanks, ill look into it – TM. Nov 25 '09 at 17:40

You can also edit the style under preferences to be 'hidden'.
Edit->Preferences->Fonts and Colors->Indicators (tab)-> Style: (look for Hidden).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .