Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently upgraded my hard drive, CPU and added a stick of RAM to bring my total up to 6GB. Now when I boot my computer, if I don't go into the BIOS and select the boot device, and manually select my hard drive, I will get a "Disk read error occurred. Press Ctrl+Alt+Del to restart" error on a black screen. If I do go into the BIOS and select the hard drive, everything works perfectly and there are no issues. I ran the Windows 7 disk check tool and it didn't find anything wrong, and as I recall it booted fine without going through the BIOS one time afterwards, but now I get that error unless I go through the BIOS.

At this point it's more an annoyance than anything else, since the computer boots and works fine when I go through the BIOS, but what can I do to fix this crazyness without having to reinstall Windows 7?

share|improve this question
2  
Which device is the BIOS set to boot from? IS there a second (not bootable) drive which is accidentally set to the first choice? Either HDD, USB pen drive, connected SDcard, ... –  Hennes Mar 25 '13 at 22:05
    
It's set to boot from the DVD drive (which also seems to work fine as I can install software), so if I were to insert a bootable DVD/CD it would run that ("Press any key to boot from disc..."), and otherwise boot from the HDD. I've always had it configured that way and never had issues. –  Wayne M Mar 25 '13 at 22:23
    
Most CD drives are accepted as removable media and indeed should not yield any problems. Same for floppy drive (with no inserted unbootable disk). But the behaviour you get does match one where a device is present and set to boot, but without an installed bootloader. –  Hennes Mar 25 '13 at 22:55
    
@WayneM If you restart Windows does it boot, or does this only happen during a cold boot? –  Louis Mar 25 '13 at 23:11
    
What happens if you set the HDD as the first boot device? If the hard disk and RAM are fine, try resetting the BIOS to defaults. If that doesn't help, try changing the CMOS battery. –  Karan Mar 26 '13 at 13:26

2 Answers 2

Download the utilities for your hard drive, Western Digital Lifeguard for WD, Seatools for Seagate etc. Test the drive with that software just to be sure.

If that passes, make sure you are backed up (Just to be safe for the next step).

Boot from the Windows 7 DVD, and choose the options for fix-mbr, there is another option along the lines of fix start-up. If you had gone to hibernate when you upgraded your RAM, it is possible it is trying to load that config which would not work since the amount of RAM changed.

You can also remove the new stick of RAM and see if the issue persists.

share|improve this answer
  • Click Start → Computer
  • Highlight OS/C
  • Right click → Properties
  • Go to Tools → Error Checking, Click "Check now"
share|improve this answer
    
And how's he gonna do that when he can't boot to the OS? Read more carefully. –  HopelessN00b Jun 18 at 3:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.