Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I really want to make Windows 7 understand that RTC in using UTC instead of local time. I found a solution, except for it does not play well with time synchronization.

I have:

  1. Modified the registry as needed and rebooted the system several times.

  2. Under "Internet Time Synchronization" as available in "Internet Time" tab of "Date and time" dialog (due to localization naming may slightly differ) set hostname to "localhost" (which is not running NTP server), tried to sync, then unticked the checkbox.

  3. Disabled the scheduled task to sync clock weekly and made sure W32Time service is stopped.

  4. Just in case, re-checked that DHCP server does not announce any NTP servers or other extra options.

  5. Ran w32tm /config /syncfromflags:NO. Although it reports success, I'm not sure this does anything useful, as the service's not running.

  6. After all of the above's done, manually set the date/time and timezone to correct values.

Clock runs fine for a some time, however, after an hour or so it's reset to a wrong value. The change happens only once, then wrong time persists. The machine does not sleep or hibernate.

I've checked the Event Log and the only messages are from Kernel-General, mentioning just the fact system time was changed, but no reason why did that happen. Enabling privilege use and process spawn audit logs does not reveal any activity near the time clock jumps - no privilege elevations near the jump, and the only process spawn is taskhost.exe right after the clock changes (which is, I persume, normal).

How could I completely disable this annoying behaviour? I suspect this happens when Windows tries to update hardware clock, but I'm not really sure. If that's the case then I'm fine with even never syncing time back to hardware clock.

share|improve this question

Just to clarify your hardware clock is to UTC +0 offset. Have you set Windows Date and Time "Timezone" to UTC - if not what timezone location have you selected and what is the UTC offset?

If Timezone location in windows is set to UTC +0 then try testing with the NTP server to see if it makes a difference.

Could it be a third party anti-virus doing a sync?

share|improve this answer
your answer is more of a comment, i understand with low rep you can't comment but with posting comments in answer you would simply be getting down votes so it's counter productive to get rep. and this is a 3 year old questions Person might even have moved to new OS who knows – SeanClt Mar 27 at 16:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.