Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I tried to set up my .emacs init file in the locations recommended by this website, but both seem to be either not doing anything or warning me the location of .emacs there is deprecated:

c:\Documents and Settings\user\Application Data\.emacs
c:\

Where should I set the init files in emacs to have it working on Windows 7?

share|improve this question
    
Do the answers to this question help? – legoscia Mar 26 '13 at 10:22
up vote 1 down vote accepted

I found out the best way is from a previous question: execute M-x customize and check where is the customization saved. In my computer, it turns out the directory is:

c:/Users/myusername/AppData/Roaming/.emacs
share|improve this answer

Another solution outside of customize is to define your %HOME% environment variable to point to a folder that is not obfuscated far deep in the local user "roaming" files.

  • windows key + pause / advanced system settings / Environment variables:
  • add a new variable for the current user
  • name it HOME
  • set its value to a folder (existing, e.g. c:\seki), that will be mapped to the ~ directory where Emacs puts its files by default, e.g. ~/.emacs
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .