Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hi I'm attempting to change a user's password. So I connect as root and just

    passwd Joe

Here I've got a little prompt, I enter a new password, twice and I get this :

    Password changed

So far so good. However if I try to login as Joe@webserver or to ssh joe@webserver ls (for example). It asks for my password, which I enter. I get the prompt three times and

    permission denied(publickey, keyboard-interactive)

Is it possible that the person that originally created that user put some weird restrictions on it? I checked the shadow and passwd files (without changing anything ofc) and everything looks fine.

Sorry if my question is not relevant or if I haven't browsed enough but I've been searching since yesterday why or how this could happen and really can't wrap my mind around it.

share|improve this question

migrated from stackoverflow.com Mar 26 '13 at 10:38

This question came from our site for professional and enthusiast programmers.

    
You better use authentication without password, but key –  Roman Newaza Mar 26 '13 at 9:19
    
@Roman sorry I'm not used to working with server related operations how do I do that, a link to a man page or anything would be appreciated if it's not too much to ask. –  Kestion Mar 26 '13 at 9:48
    
    
@Xaerxess but how can I achieve that since at one point I'm being asked joe's password and I don't have it and am unable to change it –  Kestion Mar 26 '13 at 10:18

2 Answers 2

up vote 1 down vote accepted

Thanks to Chewi and Xaerxess I used authentication keys which was way more logical, however my home dir was encrypted so I was unable to copy my key to the server. This helped https://help.ubuntu.com/community/SSH/OpenSSH/Keys.

share|improve this answer

It looks like password authentication has been disabled because it is not one of the mentioned methods. As commented above, you're better off using public key authentication anyway. Read up on it somewhere and put your public key into ~joe/.ssh/authorized_keys. Don't forget to set the owner to joe otherwise it won't work.

share|improve this answer
    
yes but I can't go passed this step since it's asking for the jo's password which I don't have and can't change it. sudo cat ~/.ssh/id_rsa.pub | ssh jo@webserver "cat - >> ~/.ssh/authorized_keys2" if I try using a newuser I get a permission denied anyways. –  Kestion Mar 26 '13 at 10:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.