Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

It came to me in a week or so that certain pages (Facebook, StrackOverflow, some news sites) have text rendering errors in Firefox. As a workaround if I refresh the page, or simply select and deselect the buggy text, the unpleasant effect disappears.

Noisily rendered text in Firefox

I don't have this effect in Internet Explorer or in any of my desktop applications.

  • Windows 7 Pro 64bit (fresh)
  • Firefox 19.0.2 (fresh)
  • Ati Radeon HD 4600 Series (fresh drivers)

Thanks for the help in advance!

Update 1/2

I have only three addons: Forecastfox, Hungarian spell checking dictionary and Quick locale switcher. The latter two are installed after the effect appeared. I disabled the first individually and did not helped.

But if I start my firefox with disabled addons I cannot reproduce the error. As far as I know this mode does not mean disabled plugins, which I do have (Adobe Acrobat, Citrix ICA Client, Google Earth plugin, Google update, Java Deployment Toolkit 6, MS Office 2010, MS Windows Media Player Firefox, Shockwave Flash, Silverlight, VLC Web).

Update 2/2

If I disable all plugins and extensions I still have the problem. If I start Firefox with disabled addons then I cannot reproduce the problem.

share|improve this question
3  
Did you installed any extensions? –  netme Mar 26 '13 at 11:22
    
All right... Extension list on the way... :-) –  Notinlist Mar 26 '13 at 11:23
    
That was a very good question. Started firefox with disabled addons and the effect disappeared. Do you have any good guess in advance about the suspect? I'm starting the searching now by enabling/disabling them, etc... –  Notinlist Mar 26 '13 at 11:34
1  
Remove them all, then add them one at a time until you find the error. @netme, should this not be moved as an answer? –  Dave Mar 26 '13 at 11:56
1  
After reading this and this I tried disabling my hardware acceleration and it seems to have done the trick. This makes no sense though because in those threads people were reporting the opposite (that turning acceleration ON fixed their problem). Moreover, it is stupid that I should have to have acceleration disabled. :-/ –  The111 Mar 28 '13 at 6:58

2 Answers 2

I'll try to summarize all comments in one answer. Probably, the problem is in one of the installed addons. Please, try the following steps.

  1. Disable extensions you've installed recently.
  2. If it doesn't help, try to disable all additional toolbars and advertisement blockers.
  3. Try to disable zoom addons
  4. If it doesn't help, disable all plugins and try to turn them on one by one.
share|improve this answer
    
1. Done. 2. Not applicable. 3. Not applicable. 4. In progress. –  Notinlist Mar 26 '13 at 12:13
    
Disabled all plugins and extensions. The effect is still there. If I start Firefox in disabled addons mode then the effect is not there. –  Notinlist Mar 26 '13 at 12:39
    
I'm not 100% sure, but it can be possible that you have some old plugins which are incompatible with your Firefox version. In this case, reset will help you. –  netme Mar 26 '13 at 13:14

After reading this and this I tried disabling my hardware acceleration (Tools -> Options -> Advanced -> General -> Browsing) and it seems to have done the trick. This confuses me though because in those threads people were reporting the opposite (that turning acceleration ON fixed their problem).

Moreover, there are downsides to having acceleration disabled. But for me, at least, it seems to fix the text problem (even if it introduces a few other more subtle, less annoying problems).

So, try playing with that setting and see if it helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.