Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Linux Mint 14 KDE and I have a GeForce 9600 GT. I am trying to use nvidia-settings (driver version 304.84) to save my dual monitor configuration:

Small monitor: TwinView, Resolution Auto (1280x1024), Position Left of (big monitor).

Big Monitor: TwinView, Resolution 1680x1024, Position Absolute +1280+0, refresh auto, Primary display for the XScreen.

This configuration works well when I apply it, so I only want to save it. However when I restart the Xserver, the configuration gets lost, and the big monitor is set to resolution 1280x1024 and as a clone of the small. The xorg.conf file is saved correctly, but it is not working later. I have tried playing around with the settings, but no configuration seems to be saved well. In particular the resolution of the big monitor is set to 1280x1024 even when the small one is disabled. Everything used to work well with the kde config before I installed nvidia drivers. The xorg.conf file produced by nvidia settings is this:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 304.51  (buildd@batsu)  Fri Oct 12 12:53:54 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics W2042"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9600 GT"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DFP: 1680x1050 +1280+0, CRT: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question

1 Answer 1

In the end I solved it by using the KDE config tool. This is the right relevant line:

Option         "metamodes" "DFP: 1680x1050 +1280+0, CRT: 1280x1024_75 +0+0"

Nvidia app is pretty crappy...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.