Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Here's what I get when I type it in via the command line:

[prompt]$ sudo yum install nginx
Loaded plugins: priorities, security, update-motd, upgrade-helper
http://nginx.org/packages/rhel/latest/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: nginx. Please verify its path and try again

I tried creating a /etc/yum.repos.d/nginx.repo file as described here but got the same thing. Any ideas?

I'm running "Amazon Linux AMI release 2012.09".

share|improve this question
    
Never mind... nginx.repo existed but was empty. Deleting it seems to have fixed it.. –  neubert Mar 26 '13 at 19:37
    
you should answer this yourself and accept the answer, to close this out. –  Rich Homolka Mar 26 '13 at 20:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.