Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Here's what I get when I type it in via the command line:

[prompt]$ sudo yum install nginx
Loaded plugins: priorities, security, update-motd, upgrade-helper
http://nginx.org/packages/rhel/latest/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: nginx. Please verify its path and try again

I tried creating a /etc/yum.repos.d/nginx.repo file as described here but got the same thing. Any ideas?

I'm running "Amazon Linux AMI release 2012.09".

share|improve this question
    
Never mind... nginx.repo existed but was empty. Deleting it seems to have fixed it.. – neubert Mar 26 '13 at 19:37
1  
you should answer this yourself and accept the answer, to close this out. – Rich Homolka Mar 26 '13 at 20:24

I also caught that problem, try this:

vim /etc/yum.repos.d/nginx.repo

Change the repo site:

[nginx] 
name=nginx repo 
baseurl=http://nginx.org/packages/centos/6/$basearch/ 
gpgcheck=0 
enabled=1

So: http://nginx.org/packages/centos/6/$basearch/

Please read the instructions completely:

Due to differences between how CentOS, RHEL, and Scientific Linux populate the $releasever variable, it is necessary to manually replace $releasever with either "5" (for 5.x) or "6" (for 6.x), depending upon your OS version.

See also: http://serverfault.com/questions/531045/nginx-repomd-xml-404-not-found

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .