Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to resolve intranet sites on my company network... What's the preferred way to reset the network interfaces after editing /etc/network/interfaces?

If I do:

sudo /etc/init.d/networking restart

It gives me:

Rather than invoking init scripts through /etc/init.d, use the service(8) utility, e.g. service networking restart

Since the script you are attempting to invoke has been converted to an Upstart job, you may also use the stop(8) and then start(8) utilities, e.g. stop networking ; start networking. The restart(8) utility is also available. networking stop/waiting networking start/running

It also, very strangely, changes my whole desktop environment to something like what it must have looked like 10 years ago. All the icon textures change to look older and my hotkeys and other swag stop working.

So I tried the suggestion in the output after restarting the computer...

sudo service networking restart

And it changes my desktop environment again without actually resetting the network interfaces. Is there some other command that will actually make my changes to /etc/network/interfaces live and not mess up my desktop environment?

share|improve this question
You seem to have a problem with your graphics drivers because the command you are trying will never affect anything other than bringing down/up your interface. It is the right command to do after changing your network settings. Check if your graphic card is configured with suitable drivers. – paintbox Mar 29 '13 at 10:59
My drivers are installed correctly. It's not a graphics driver issue. That command changes the mint desktop theme-- the graphics are rendering correctly-- it doesn't totally bug out or anything. It literally seems only to change the desktop environment theme. – kelorek Mar 29 '13 at 18:24

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.