Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Sublime Text 3, and the auto-indent is a problem for me. Basically, all I want is auto-indent to the same indent level as the previous line, similar to gedit's dumb but predictable behavior. But Sublime Text's auto-indenter adds an additional tab (=an additional four spaces) after a colon (for instance, after class SomeClass(...):).

I thought this was what the smart_indent option was for, but unfortunately disabling that doesn't seem to disable this feature. Disabling auto_indent altogether, of course, turns off even the dumb indentation.

Is there any way to configure Sublime Text to stop doing this, or even override that behavior with a custom plugin?

(I wanted to post this with a sublime-text-3 tag, but it does not exist yet. For what it's worth, the configuration options and their documentation is identical in Sublime Text 2, so behavior may be identical too.)

share|improve this question
    
have you tried setting smart_indent to false in Sublime Text 2 to see if that works? ST3 in my experience is still lacking a number of features, so this just might not be implemented yet. (And besides - I like smart indent!) –  MattDMo Mar 27 '13 at 1:05
    
I have not tried Sublime Text 2, but I'm willing to give it a shot if it might fix this issue. –  Andrew G. Mar 27 '13 at 1:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.