Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I run one of the following commands:

rvm install jruby-1.7.3

or

rvm install jruby

I get the following message:

Searching for binary rubies, this might take some time.

Installing requirements for ubuntu, might require sudo password.

Running 'apt-get --quiet --yes update' would require sudo.

Cowardly refusing to continue, please read 'rvm autolibs'.

Updating repositories

Missing required packages: git-core.

Cowardly refusing to continue, please read 'rvm autolibs'.

and

rvm --version

gives me

rvm 1.19.0 (latest) by Wayne E. Seguin , Michal Papis [https://rvm.io/]

Could anyone advise how to fix this?

share|improve this question

migrated from stackoverflow.com Mar 27 '13 at 8:36

This question came from our site for professional and enthusiast programmers.

2  
the command asked you to read rvm autolibs - did you? –  mpapis Mar 26 '13 at 20:11
    
@mpapis Actually doing this and looking thought the output solve my issue. –  gotqn Mar 26 '13 at 21:48
add comment

3 Answers

up vote 3 down vote accepted

The issue was fixed with just running:

rvm autolibs enabled

When I firstly run

rvm autolibs status

and the output was "disabled", where allowed modes are as follows:

  • 0, disable, disabled - Limit RVM automation as much as possible.
  • 1, read, read-only - Allow RVM to use package manager if found but do not install or fail if dependencies are missing.
  • 2, fail, read-fail - Allow RVM to use package manager if found, fail if dependencies are missing. This is default.
  • 3, packages, install-packages - Allow RVM to use package manager if found, install missing dependencies.
  • 4, enable, enabled - Allow RVM to use package manager if found, install missing dependencies, install package manager (only OSX).
  • brew, homebrew, osx_brew - Like 4 but forces use of Homebrew.
  • port, macports, osx_port - Like 4 but forces use of MacPorts.
  • fink, osx_fink - Like 4 but forces use of Fink.
  • smf - Like 4 but forces use of SM Framework.
share|improve this answer
add comment

Looks like you might need to install git sudo apt-get install git

share|improve this answer
    
I have installed it but the error messages appears again. –  gotqn Mar 26 '13 at 20:06
add comment

I got similar error when installing ruby

Missing required packages: git.

Cowardly refusing to continue, please read 'rvm autolibs'.

Take a look at the instructions on the following link, it may help you.

https://www.digitalocean.com/community/articles/how-to-install-ruby-on-rails-on-centos-6-with-rvm

Note that after installing rvm you probably have to install additional dependencies using following command before you install ruby (this is listed in the link)

yum install -y gcc-c++ patch readline readline-devel zlib zlib-devel libyaml-devel libffi-devel openssl-devel make bzip2 autoconf automake libtool bison iconv-devel

NOTE: For centos >= 5.4 iconv-devel is provided by glibc

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.