Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a quick question. Apologies if this has been posted already, but I have searched and can't seem to find what I am looking for.

I have a localhost , Host 1 and Host 2.

The Host 2 machine has access to a specific network, but will only accept connections from Host 1, and Host 1 will only accept connections from localhost. This is a basic SSH multi-hop, I know how to do this part; using Putty.

What I wish to do however is share this SSH connection with my NIC. This way I can use local administration tools against the Host 2 network and also access specific machines on the network.

Using Putty, I created a proxy using localhost using port 1024, which I could then configure with Firefox using the same settings. I could then view the apache2 default website, proving I had access to that machine. The problem I am having is being able to do this on my Network Card, as if I was sharing that machines connection.

Is this possible?

Localhost = Windows & Linux\n Host 1 = Linux\n Host 2 = Linux\n

share|improve this question

The simplest solution is to do SSH port forwarding (as you seem to mention you know how to do) then set up the system-wide proxy settings to point to "localhost" and the port that you forward through. This is effectively tunneling all your traffic through from Host 1 to Host 2.

This guide might help: http://www.techrepublic.com/blog/security/use-putty-as-a-secure-proxy-on-windows/421

share|improve this answer
    
I have set up my SSH with port forwarding this time, doing the following: ssh username@host1 - L 4444:host1:9090 Once connected to the first host, typed the following: ssh -D 9090 username@host2 This then connects me to Host 2. I then configure a system wide proxy on Socks as LocalHost:4444 Surely this should work? It doesnt seem to be. I have also tried replacing the system wide proxy with the tool tsocks, though that has yielded me no results either =/ Apologies for the poor formatting, text seems to be coming up as one block of writing.. – Dwyn Mar 27 '13 at 17:37

Seems this has worked well for me.

http://dev.squarecows.com/2012/03/06/using-ssh-as-a-reverse-tunnel/

share|improve this answer
    
That link is dead – Brian Vandenberg Mar 17 '15 at 7:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .