Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to connect to a ISP provider who is running a DHCP service.

When I connect the cable provided by the ISP[beam telecom] to my laptop , a dynamic IP is assigned and everything fine.

When I am using TP Link Router WR740N(new) instead, dynamic IP is not assigned to the router.

I checked and compared logs from the router and laptop when connected to the cable , I observed the following difference

while my laptop running windows 7 even after a failed attempt persistently looks for an IP, while my router just quits the first time.

my question is how to configure the router to look for the IP continously, I checked the web interface for an option but I could not find one.

can I do a telnet to the router and change the configuration?

share|improve this question
    
It's possible your isp is restricting dhcp addresses to the mac addresses of the routers it issues it might be worth looking for an option to change your new router's address to the one of your old router. –  Col Mar 27 '13 at 10:11
    
this is the first time I am using a router with this ISP, I tried to clone the mac address of my laptop to use with the router(using option in the web admin interface),but no luck. –  flash Mar 27 '13 at 10:18
    
Not the one of your laptop, the one of the router they gave you. That's what they are expecting to get the address request from. –  Col Mar 27 '13 at 10:23
    
I think you should be looking for the problem elsewhere. Why isn't your router getting an IP in the first place? Having it resend a DHCP request immediately will make it fail more often, but doesn't mean it will eventually succeed. –  Marcks Thomas Mar 27 '13 at 10:24
    
I guess the dhcp service from ISP might be taking some time to respond, this problem is handled by windows 7 by retrying while the router cannot. –  flash Mar 27 '13 at 10:34
show 5 more comments

1 Answer 1

Many times the ISP's modem sees the Mac address as "sticky" so when changing devices you most power down the modem, power down the device (router, system, etc.). Power the modem back on, wait for it to complete its start-up then power on the device. Also make sure that the router is properly connected and set to accept a DHCP address. Another check would be the cable - your laptop may do auto-xover and your router may not, so if your cable is of the wrong type the laptop will still work but the router will not.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.