Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Remote Desktop stopped working on my Windows 7 machine. This is a huge problem because I need to use RDP to work away from home.

Nothing has changed. My router is still using DDNS properly, the ports are forwarded, and Windows Firewall has exceptions for RDP.

If I turn off Windows firewall, I can gain access, but that's not a permanent solution. I've tried everything from refreshing exceptions to manually opening ports in the firewall. None change the situation. The ONLY thing that works is turning off Windows Firewall.

Please help. I'm beyond frustrated with this issue.

Additional Info:

I am unable to stream media from my machine as well. I did not notice this until just now. It seems like all incoming connections to my machine are blocked?

I am able to use Wake On Lan to wake my machine so packets are making it to the machine over WAN.

share|improve this question
    
This is not the answer you want, but I just wanted to point out that security-wise, this is not a very safe practice. Ideally you need to setup a VPN at your home and do your RDP only from there. At worse you could setup SSH tunneling for RDP, so you got that extra layer of security. –  Astaar Mar 27 '13 at 9:59
    
Do you use any other firewall other than Windows? Does your AV for example, come with a firewall? –  Dave Mar 27 '13 at 10:33
    
I am using Microsoft Security Essentials –  Kashif Mar 27 '13 at 10:56
    
I have made a last ditch effort with "Restore Defaults" in Windows Firewall and that seems to have allowed me to resume normal RDP usage on LAN. I have yet to test whether RDP will work over WAN. –  Kashif Mar 27 '13 at 11:23
    
My suggestion is to try RDP on another machine. Or another pair of machines. –  Guy Thomas Mar 30 '13 at 10:10

3 Answers 3

up vote 1 down vote accepted

I have made a last ditch effort with "Restore Defaults" in Windows Firewall and that seems to have allowed me to resume normal RDP usage on LAN. I have tested this over WAN and it works as well. Hope this helps someone in the future.

share|improve this answer

Please try

Open Windows Firewall.
Click the Exceptions tab.
To enable the remote desktop exception, in Programs and Services, select the Remote Desktop check box, and click OK.
To disable the remote desktop exception, in Programs and Services, clear the Remote Desktop check box, and click OK.

Or from the command prompt

netsh firewall set service type = remotedesktop mode = enable

(or type disable)

Source

share|improve this answer
    
I have tried this before with no success. I tried the cmd command. No such luck still. –  Kashif Mar 27 '13 at 10:26
    
Please explain what you mean by no success - that it doesn't change the value within Windows Firewall or that it does but you still can't RDP? –  Dave Mar 27 '13 at 10:29
    
It changes the value but I still cannot RDP –  Kashif Mar 27 '13 at 10:55
    
Right.. does it change the value for only Domain or Private or Public? –  Dave Mar 27 '13 at 10:58
    
It changes it only for my Private network –  Kashif Mar 27 '13 at 11:03

I have found that some printer drivers cause the RDP to immediately fail. Go into advanced options, uncheck the local resources->printers box and give it a shot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.